Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Can't play free

First BioWare Post First BioWare Post

tupacfan's Avatar


tupacfan
11.15.2012 , 05:56 PM | #1
Hello I'm trying to play free but it keeps telling me "there is no active account subscription on this account, activate your account here" I click the link and nothing. It just says download for f2p but I already downloaded months ago for beta.

ganzgeil's Avatar


ganzgeil
11.15.2012 , 06:04 PM | #2
Have the same problem tried repairing and fix launcher but nothing worked so far.

Beesodd's Avatar


Beesodd
11.15.2012 , 06:12 PM | #3 Click here to go to the next staff post in this thread. Next  
Hi tupacfan,

You may need to download a fresh client, if all you have is the beta client from back in November/December. Try download and run the setup file over your existing install, and try again.

Beesodd | BioWare Customer Service - Forum Support

alumja's Avatar


alumja
11.15.2012 , 06:15 PM | #4
I'm also having this issue. I have downloaded the newest version and patches. I can log in with a different account so this isn't a game version problem.

The launcher says :

"There is currently no active subscription on this account. Activate your account here."

XiledOne's Avatar


XiledOne
11.15.2012 , 08:00 PM | #5
I am also having this issue with a fresh install.

LeonK's Avatar


LeonK
11.15.2012 , 08:17 PM | #6
Same issue here.

hopelessnerd's Avatar


hopelessnerd
11.15.2012 , 08:18 PM | #7
Also having this same issue, fresh install - repaired...no such luck.

allenmon's Avatar


allenmon
11.15.2012 , 08:28 PM | #8
I also participated in the beta tests but I deleted all those files back when the beta was over. I just finished downloading and installing the game and receive the same error about not having an active subscription when I log in.

TaoAlchemist's Avatar


TaoAlchemist
11.15.2012 , 08:28 PM | #9
I have a very similar issue. I am still subbed, but my son wants to have free to play account and use the same computer as me. I just downloaded the latest version of the game earlier today and we created his account on the website. I then try to log him in and we get the message about having an account associated that the poster a couple posts above mentioned.

I can still log in to my account, but he cannot log in to the new one we created for him. When we check out his account on the website, it will only let us choose from subscription models and there is no free to play option for him to pick on his account.

So, we are stuck and my son cannot even so much as create a character. In the mean time, I have delete one of my characters so that he could reserve the name he wants for his guy on the same server (we have plans to get him his own computer later so we can play together).

UntouchableNC's Avatar


UntouchableNC
11.15.2012 , 08:50 PM | #10
I am having the same issue. I have an account that I created 08/14/2010 but I never purchased or played the game. I wasn't in the beta and downloaded a fresh client just today. I can login successfully through the launcher, but am unable to play the game. The launcher states "There is currently no active subscription on this account. Activate your account here." The link takes me to my account page and states that I am a free player.

Perhaps this is an issue with accounts made before the F2P model? Help would be appreciated.