Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Item Preview Window

First BioWare Post First BioWare Post

battycoda's Avatar


battycoda
11.18.2012 , 10:53 AM | #11
Quote: Originally Posted by Tirvaak View Post
Hi battycoda,

I'm glad to hear it is resolved for you now.

@jzredemann; We are aware of some problems with the preview window as you can see from the known issues list. Out of interest where in the game have you tried to use the preview window(fleet/ship/Section X/other planets) and did it work correctly in any of these locations?

Thanks.
It didn't stay resolved. When I came back today, it was not working again. It was working on my ship for a while but now it only works on my own preview on Fleet. Mako is still showing only feet. The other comp that shows is Blizz and he never changes no matter what you put on. Nothing works anywhere else right now. The funny thing is that it is hit or miss on my alts. Sometimes it works, sometimes not.

I have tried on Fleet, my ship, Corellia, Belsavis, Ilum, and Tattooine.

battycoda's Avatar


battycoda
11.18.2012 , 11:00 AM | #12
Quote: Originally Posted by Kagela View Post
I am having what appears to be the same issue.

Specifics:
I am testing this on a level 43 Imperial Agent Operative, on Belsavis (regular).
I have the following companions unlocked:
Kaliyo
Vector
Ensign Temple
Doctor Lokin
SCORPIO
Ship Droid 2V-R8

When Kaliyo or Temple manage to pop up in the Companion tab of the Item Preview window, all I see is one or two feet. Usually (always?) they are naked feet.

When Vector, Lokin, SCORPIO, or 2V-R8 are in the preview window, it works as intended.

When I try to cycle through companions, I cannot cycle to Kaliyo or Temple. If they are next in the rotation, it will not go to them, instead keeping the current Previewed companion's name and going to a gray, empty screen for the character display.

If I open the Preview tab and Kaliyo or Temple are currently loaded, I get the bare foot/feet; I can cycle off of them but not back on. (if it brings up Kaliyo, I can go forward to Vector or back to 2V-R8. If I go to Vector, I cannot leave Vector until I zone or toggle the UI off and back on - as Ensign Temple is next in the cycle, Vector is bracketed by females.)

I have tested that this occurs whether I am on my ship (which, btw, I never did get the Codex entry for), on Belsavis (regular), on Ilum, or on Alderaan. In Section X, I get the Known Issue preview window failure. Interestingly, I had the same issue on Corellia as in Section X: No preview at all, even on my tab. Still cannot even cycle the name bar of the companion preview tab to Kaliyo or Temple.
This is exactly how it is happening for me. As Mako is my only female comp on the Bounty Hunter, I can't say if this is with females since it seems his is. But I get 2 naked Mako feet. The droid and Blizz show fine but they never change no matter what you put on them. Gault and Skadge are hit and miss but generally they only show what they currently have on. If I move away from Mako to one of the others, I can't even load her back. I have to zone out of where I am or completely reload. The window get stuck on whatever comp was the last to be looked at.

But it is not a consistent thing. Today, I got to see some pants on Mako after she showed up with just feet. But when I looked at a top to go with the pants, she vanished completely and never came back.

On a side note, she makes for a great weapon preview because she is invisible and the weapons how. I can look at them from every angle.

Christopher_Epps's Avatar


Christopher_Epps
11.18.2012 , 11:28 AM | #13
Mine was doing the same thing yesterday before I got booted off and now I can't get back on. I tried out the purple crystal on Corellia but all I could see was a purple blade.
"He who does not punish evil, commands it to be done."

battycoda's Avatar


battycoda
11.20.2012 , 12:17 AM | #14
Anything on this yet? The idea behind custom armor is being able to choose your look and have the mods you want make it functional. It has been a week and the only things asked is where I was when it does it. I'm everywhere when it does it. My female comps are just 2 naked feet. My male comps only wear what they have on. I can see myself if I angle the camera just right. It is everywhere in the game.

Kagela's Avatar


Kagela
11.20.2012 , 08:41 PM | #15
As Wolvereen suggested in this post, it appears to have something to do with Companion Customization skins. I take the Customization off Temple and Kaliyo, preview works. I put it on, preview breaks. I preview it, and it previews... so long as it's not on them at the time.

Have not yet tested this in places that I had no previews visible at all.

battycoda's Avatar


battycoda
11.20.2012 , 11:39 PM | #16
Quote: Originally Posted by Kagela View Post
As Wolvereen suggested in this post, it appears to have something to do with Companion Customization skins. I take the Customization off Temple and Kaliyo, preview works. I put it on, preview breaks. I preview it, and it previews... so long as it's not on them at the time.

Have not yet tested this in places that I had no previews visible at all.
I am off to try this now! I wanted to add that I have done some more steps. I have set each graphics setting from lowest to highest, changed to full screen, full screen windowed, and windowed, and all graphics modes I have between 1440x900 and 1920x1080. I also installed the latest Beta drivers for the AMD Catalyst Control Center. Those DID NOT work. I am now going to verify the customization skins noted above!

EDIT: The above worked. Remove customization skins and your comps return!

battycoda's Avatar


battycoda
11.21.2012 , 01:17 AM | #17
Thread information consolidated here with all troubleshooting information for CS to pass on to the devs. I have also filed a ticket with this information as well as Wolvereen's suggested workaround. Hats off to you, Wolvereen!

Tigalo's Avatar


Tigalo
11.25.2012 , 04:41 AM | #18
Removing custom skins did not work for me.

The odd thing is, I only have this problem on one character (which is on Corellia btw), my other 11 characters work fine.
Nite Legacy (legacy level 50) on The Progenitor: Kir - 55 merc, Tigalo - 55 jugg, Kirana - 51 sorc, Jax 50 marauder, Rev - 50 operative, Nish - 50 gunslinger, Kenix - 55 sage, Manji - 50 assassin, Tigelo - 50 Commando and more

Glower's Avatar


Glower
11.26.2012 , 05:51 AM | #19
Quote:
Character Preview does not work as intended in Hard Mode Flashpoints.

The Preview Window does not work as intended in Section X.

The Preview Window may display incorrectly when inspecting other players with the Character Window open.

Some items appear with low quality graphics in the Preview Window.
But my window bugged on fleet (shows me only zoomed feet ). Pls fix it.
SWTOR goes F2P: http://i.imgur.com/1962X.jpg
A: "They’d love to do that at some point, but technically very challenging and unlikely to happen in the near future." (c)
PvP FAQ, A: "We have no plans at this time" (c)

Glower's Avatar


Glower
11.27.2012 , 08:31 AM | #20
And again, this is not fixed in 1.5.1, nice work Bio-not-aware!
SWTOR goes F2P: http://i.imgur.com/1962X.jpg
A: "They’d love to do that at some point, but technically very challenging and unlikely to happen in the near future." (c)
PvP FAQ, A: "We have no plans at this time" (c)