Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Information Request: Crashing to Desktop

STAR WARS: The Old Republic > English > Customer Service
Information Request: Crashing to Desktop
First BioWare Post First BioWare Post

LaOosaki's Avatar


LaOosaki
12.16.2012 , 12:05 PM | #401
Can anyone tell me if removing the game completely then reinstalling it from zero can fix the memory leak?
The Firebrand Legacy --Founder

Living Legend

LaOosaki's Avatar


LaOosaki
12.16.2012 , 03:07 PM | #402
I fixed the problem on my notebook. I have no idea how, but after posting my specs here I did some research and tried 3 things:

First: Updated Java to the latest version. Don't know if that changes anything, but I'm counting it on the stuff I did today.

Second: Ran this:

Third: Ran my SWTOR_setup.exe file and proceeded with the installation. It set all the files back to default, then I opened the launcher and used the Repair tool. Launched the game and set graphics to very high, then back to low and then set the configuration I'm used to play with.

I am also using this program to manage memory use: and I'm playing with Catalyst forcing anisotropic to 16x and v-sync always off.

I went into several warzones, loading screens, traveled around the planets, entered conversations and combat - no crash, no freezes, no stuttering around.
Hope this helps.
The Firebrand Legacy --Founder

Living Legend

dtbond's Avatar


dtbond
12.16.2012 , 03:28 PM | #403
I too have tried troubleshooting this with no real resolution. I decided yesterday to uninstall, reboot and do a clean install from download. After letting it dl overnight, I ran setup this morning and it worked fine for 30-45 minutes. Now, upon return, it once again consistently crashes back to desktop.

I'm not going to bother opening a support ticket with BioWare; my time is far more valuable than to be wasted sitting on the phone for a rep. In the absence of Bioware fixing this problem (which did not start for me until after 1.6), I'll continue to peruse the forums and the web looking for a solution.

Every system is different, but there's something wrong in their client for the number of people having this issue to still not have a resolution or workaround.

BlackSpin's Avatar


BlackSpin
12.16.2012 , 05:41 PM | #404
I just got booted out and it said "Connection to the server lost." Then I tried to get to the server menu to log back in and it said "This account is not authorized..." Then the game client wouldn't respond to anything. I had to "Ctrl-Alt-Del" to the get task manager up, at which point I saw the game was using 3.6gb of ram (laptop only has 4gb.) I killed the client, and logged back in, and it was fine. So,... memory leak you say?

suggy's Avatar


suggy
12.16.2012 , 08:01 PM | #405
1. Name of server: The Harbinger
2. Name of character(s) affected: Fe'shulia
3. Frequency of crashing – how many crashes, how often? Always happens @ the end of black talon mission after you select where you want to go
4. Any potentially helpful information about crash triggers, what you are doing before a crash, etc: Selected Spacestation as return point

5.
Spoiler



6. Your reliability report
Spoiler


7. it was a crash to desktop

SuperGrunt's Avatar


SuperGrunt
12.16.2012 , 08:30 PM | #406
  • Name of server. Prophecy of the Five.
  • Name of character(s) affected. Mosy.
  • Frequency of crashing – how many crashes, how often? CTD 2 times in the past week (haven't really had that many in the entire year), Video driver crashes about 5 times a week.
  • Any potentially helpful information about crash triggers, what you are doing before a crash, etc: Exiting HMFP
  • Your DXDiag in spoiler tags
Spoiler
  • Your reliability report in spoiler tags
  • For Windows 7 / Vista:
Spoiler
  • Please specify that this is indeed a crash to desktop, not a disconnect to server select screen or a logout to character select: YES it is.
Healing, damage, tanking, it doesn't matter. I do it all. I have been doing it while winning in PVP since Beta.
My propsed changes to Loot Rules.

Tecknik's Avatar


Tecknik
12.16.2012 , 08:39 PM | #407
Quote: Originally Posted by OwenBrooks View Post
If you are using Windows 7 or Vista, could you please try running the launcher in compatibility mode for Windows XP (Service Pack 3) and as administrator
If this was a response to me, I did this and crashed after about a minute of play.
Spoiler
#The Furious Angels#
Tecknik - Ad Astra
Jung Ma Server
Website|The Signal|HQ

ClaudeTaylor's Avatar


ClaudeTaylor
12.16.2012 , 09:21 PM | #408
Name of server: Begeren Colony
Name of characters affected: Claudè, Archenon, Duval, Edualc, Elevenseven, Rolyat and Tarquinas
Frequency of crashes: Approx. every 1 to 2 hours
Any potential info: I can be sitting any where, on any planet, ship or station and the game will just crash to the desktop. It also happens when i go into my first or second wz or ranked wz . It happens when i swap to another character, a few minutes after i swap it crashes to the desktop. Also it crashes when i travel from one planet to another. especially tatooine belsavis and hoth

I am using windows xp. Also DXDiag says i have 3582 gigs of ram i actually have 4 gigs


Spoiler

OwenBrooks's Avatar


OwenBrooks
12.17.2012 , 01:11 AM | #409
Even though you have 4gb ram , Win XP 32bit can only access a maximum of 3.2gb.

Only thing i noticed in your diag is the sound drivers are from 2008 but thats about it.

There is some conjecture about memory use within 32 bit OS , Win xp didn't handle memory as well as vista and up.

Some have tried different things have a read through some of the threads as not sure what will work for your machine.

Recent post had a xp user installing a program called memory cleaner and he says his issues are gone

Commander_Ponce's Avatar


Commander_Ponce
12.17.2012 , 01:56 AM | #410
1. the bastion
2. all characters
3. once every 2 hours
4. during loading screens
5.
Spoiler

6.
Spoiler

7. game will freeze and after several minutes it will crash