Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

1.4 Client Crash

moonsparks's Avatar


moonsparks
10.12.2012 , 11:36 PM | #1
To whom it may concern,

I also have been crashing to desktop for no apparent reason since patch 1.4. I have been playing since December 17th 2011 and have not crashed one time up until this patch was released. I even went so far as to reformat my entire computers hard drive "clean installation" trying to correct the issue. My setup, Microsoft Virtual C++ 2008 SP1; everything is correct and my drivers are up to date. The only change is with what came out in 1.4. Earlier today the servers came down unexpectedly for a few hours and a patch was implemented for a graphics bug "stuttering" issue. I had hopes this would correct the problem so many are experiencing in regards to client crash. I can go about 2.5 hours of non stop play before the entire client just shuts down. That's a very bad situation when your the tank running a HM or anything else for that matter. This issue is being experienced by a lot of people. I haven't canceled my subscription because sometimes it takes a while to listen to the player base when they say "look the issue is with the game coding somewhere and not are computers". I have tried everything. Every possible solution provided. Even the lowest possible graphics settings to no avail. I'm hoping when the new content in 1.5 comes out that it will have a lot of fixes for the bugs 1.4 seems to have created. UI overlay during loading screens as an example. I haven't even so much as ever posted anything on these forums but after this last crash when I finally was selected into a war zone via group finder. That was my breaking point. With enough posts maybe it will get looked into. I will wait another few weeks to see if it gets corrected. After that whats the point in playing something when your groups going to die due to the game instability problems that are being blamed on peoples computer setups when the issue is clearly with the developers software. The first sign there is something wrong is when more then one person reports the same issue and all have tried the same exact solutions to fix the problem but the issue still exists. Just another player letting you all know somethings wrong and I don't need tech support because as i stated above "Never had a crash until 1.4.

Honani's Avatar


Honani
10.30.2012 , 07:33 AM | #2
i have the same issues since 1.4 patch. i did not reinstall windows. but i did reinstall star wars to no avail. i called them and talked to a rep. she had me make 3 files and send them to her. she told me to get a hold of HP. which makes no sense to me seeing as i have no problems with any other games i play. i agree its a problem on their end and denying the fact and blaming it on my pcs maker is just lame. they were no help not even an explanation of what the problem is. just the like weekly black hole quest bugging out on me when i completed all the requirements for the commendations that still hasnt been awarded since the 23rd. is this an example of what the game is gonna be like when it turns free to play? im sorry but if they are trying to keep the game afloat in hopes of salvaging it and all the money they spent on making and keeping it going is gonna be lost. because nobody is gonna wanna pay for a game or play for free if they cant even fixed minor issues.

LetoAtreidesII's Avatar


LetoAtreidesII
10.31.2012 , 02:42 PM | #3
USEFUL Cut and Paste Advice:

If you're getting the memory leak crashes that many/most of us have, the advice Bioware Customer Service gives may very well be of no use to you and you'd be well advised to ignore it. Instead, do the following:

1. If you have 32-bit Windows, either upgrade to 64-bit or use this method to remove the RAM cap:
http://www.evga.com/forums/tm.aspx?m=960087&mpage=1
This will allow your system to use more than 3.5 gigs of RAM, which is the hard-coded limit in 32 bit Windows.

2. If you already have 64-bit Windows, install more RAM in your system.

3. The following did not help me, but it may help you:
Increase your GDI object cap; for Windows 7 users only (adapted from Slaxinexx's original post here http://www.swtor.com/community/showthread.php?t=547744)

a. Start up your registry editor (Start -> Run -> regedit)
b. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows
c. Optional: click on the key (windows) and export it to any new file name to create a backup
d. Click on GDIProcessHandleQuota
e. Click on Decimal under base
f. The value should be 10,000 (default). Change this to 20,000.
g. Exit registry editor and reboot

More RAM available to the system will allow you to play for a much longer period of time before the memory leak causes the client to crash. It seems that for most people, this is so effective that they don't crash at all, or at least not very often.

This issue has been reported and discussed in the following threads without any official acknowledgement:
http://www.swtor.com/community/showthread.php?t=542551
http://www.swtor.com/community/showt...=538577&page=6
http://www.swtor.com/community/showthread.php?t=544501
http://www.swtor.com/community/showthread.php?t=545715
http://www.swtor.com/community/showthread.php?t=545382
http://www.swtor.com/community/showthread.php?t=541996
http://www.swtor.com/community/showthread.php?t=544474
http://www.swtor.com/community/showthread.php?t=544832
http://www.swtor.com/community/showthread.php?t=542298
http://www.swtor.com/community/showthread.php?t=539461
http://www.swtor.com/community/showthread.php?t=545666
http://www.swtor.com/community/showthread.php?t=548620
http://www.swtor.com/community/showthread.php?t=546721
http://www.swtor.com/community/showthread.php?t=549553

In each case where Bioware CS has responded to these threads, they have treated it like a new and unknown issue and thus applied their ineffective standard troubleshooting protocol. In the meantime, much of the community has correctly identified the problem. As such, it stands reason to assume that Bioware is unaware of the problem and is not working on a fix. If they were aware of the issue, Bioware CS should respond with "this issue will be fixed in an upcoming patch" instead of useless troubleshooting advice. Since a fix by Bioware is not forthcoming, users would be well advised to use the three suggested fixes above and ignore Customer Service's troubleshooting tips.

If my three suggested tips are not possible for or useful to you, there is still some hope. It is possible that Bioware will eventually acknowledge and fix this issue, since they have done so before. The memory leak crash was acknowledged and largely fixed sometime back in 1.2, unfortunately, only to reemerge in 1.4. As bad as this may seem, this is a much better track record than Trion had with Rift, which had a similar issue which was never acknowledged or fixed, at least at the time when I quit that game back in January.