Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

EC Hard Mode - Stormcaller Glitch

JKnightJ's Avatar


JKnightJ
10.03.2012 , 08:56 AM | #1
My guild ran EC HM 2/10/12 and encountered a particularly vexing situation where Stormcaller would "twitch" off the tank and cleave both the dps standing opposite (mostly) the tank for 11-22K damage. This resulted in two instakills of the dps and a raid wipe.

This only took about a second to occur. The tank never lost aggro on Stormcaller according to all of the Stormcaller team's target-of-target frames. This glitch occurred before and shortly after the first double-destruction.

On the date of the raid, there were 16 instances of Denova running. Our raid was mostly BH geared with many raiders sporting Campaign gear and was comprised of many of our best players as this was a progression run for us.

Has anyone else encountered this situation and/or successfully navigated it?

Liira Jaade - Warrior Nation - The Shadowlands

Journeyer's Avatar


Journeyer
10.03.2012 , 09:10 AM | #2
The twitchy behaviour has been happening over on Stormcaller HM for as long as I can recall (I tank it).
In dozens of attempts, I can only recall one instance in which a "twitch" went off right as the frontal cone did, wiping the raid. In general, I've tried to deal with it by moving forward and back a bit until it stops twitching--sometimes I have to stand out of melee range.

I also throw group taunt (which won't pull firebrand) periodically, just for kicks, and place a guardian bubble (I'm a shadow tank) on one of the DPS, just in case it is an issue with aggro being close. I'm not sure if the additional threat measures actually help, but we rarely get the frontal cone wipe even though we commonly get the twitches.

I guess it's a bug; I haven't thought to report it just because it didn't seem to be causing us trouble ><
I make useful, game-expanding suggestions.
Holorancor | Food! | Outfit Storage | My Career | Ultimate PvE Solution

metaIsaber's Avatar


metaIsaber
10.03.2012 , 12:27 PM | #3
I've seen it "glitch" over and do this too. I have target of Target enabled and my picture/name was there the whole time.

Pubsam's Avatar


Pubsam
10.03.2012 , 12:48 PM | #4
I've encountered this as well, and it's been pretty bizarre. I heal, and I've sat on Stormcaller with two Commandos and while the tank would occasionally twitch over, it wasn't after Double Destruction so no deaths. After wiping for an unrelated reason and switching a Commando with a Sentinel to even DPS, that Sent would make Stormcaller twitch over a few seconds after DD no matter what. He had Guard, he was Force Camoing, the tank was preemptively AoE taunting. And still Stormcaller would turn and cleave.

Makes me think that it is a threat issue of some sort since bringing in a higher threat DPS made the situation worse. Definitely screwy all around though.
Time for a nap.

wetslampigduex's Avatar


wetslampigduex
10.08.2012 , 08:02 AM | #5
Not a Glitch at all SC aggro table is very touchy. As someone who tanks SC every run I have been through my suggestion goes as follows. Do not taunt SC as soon as the fight starts go a solid 5-6 GCD before taunting in some cases id almost go as far as saying wait till the dps pulls off of you then taunt(use single taunt). Then after(or 1/2-3/4 thru the channel) of Double destruction use an AoE taunt. Before the changes to the aggro I used to have to use my taunts pretty much every time they came off cooldown, but since its fixed if follow what i just wrote and throw in a single taunt here and there you should be fine. If you watch SC while your tanking you can pretty much see if your loosing aggro he starts to kinda twitch towards the dps if you ever see this hit your taunt.