Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

The login server is currently unavailable AGAIN

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
The login server is currently unavailable AGAIN
First BioWare Post First BioWare Post

twyztd_valkyrie's Avatar

11.16.2012 , 08:19 AM | #31
Same problem, Canada -- how long are we supposed to try for, before its supposed to work? Because I'm starting to head towards 30 min of trying...

**Edit: just let me log in... dling patch now...
"So, Lone Star, now you see that evil will always triumph, because good is dumb."

Thespen's Avatar

11.16.2012 , 08:19 AM | #32
we recommend to keep trying and it should allow you to login again.

20 = tryies and still can't login

Locksley's Avatar

11.16.2012 , 08:20 AM | #33
Yep log in server is down
You will learn your place young one

E'mily (sage), Sophi'e (sorc).A'ngela (PT), lol'face (Jug).

Vikin's Avatar

11.16.2012 , 08:20 AM | #34
Quote: Originally Posted by azbestos View Post
Got the same problem.
I'm trying to log in and it says 'The login service is currently unavailable. Please visit bla bla bla'
I'm from Poland.
Warsaw, Poland here. Same thing.

Mentulaz's Avatar

11.16.2012 , 08:20 AM | #35
Well no **** the guy who posted "keep trying and it should let you in" is a complete moron. Hammering a login server thousands of times is not going to help the situation.

lollie's Avatar

11.16.2012 , 08:20 AM | #36
It's particularly annoying because it takes ages to report we can't connect (getting a swirly timer while it's trying to reach login server) then that message comes up telling us to visit forums, and we have to completely restart the launcher again



thealphaa's Avatar

11.16.2012 , 08:21 AM | #37
I can get on now

-edit- And now Its gone straight off again
Peace is a lie, there is only passion. Through passion, I gain strength.
Through strength, I gain power. Through power, I gain victory.
Through victory, my chains are broken.
The Force shall free me.

Snakebate's Avatar

11.16.2012 , 08:21 AM | #38
I have the same issue too it says
"The login service is currently unavailable. Please visit bla bla bla"

Im from UK

Raekor's Avatar

11.16.2012 , 08:22 AM | #39
Same problem here. iiNet, Perth, Western Australia.

Game dropped me and I can no longer log in on my gaming PC due to the login server message. Tried flushing my DNS, restarting my computer, going from static DNS servers to auto and the flushing my DNS again. Nothing worked.

Choloe's Avatar

11.16.2012 , 08:22 AM | #40
I got a bit further once... I got in, downloaded the patch, and then just held on the "splash/loading" screen...
"Only a Sith thinks of the Force in terms of power, a Jedi listens and feels the Force to achieve harmony with the Galaxy, and complete control and mastery of the Force." - Ancient Jedi Master A'ahrun Chengon