Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Developer Update: Shadow Optimizations in Game Update 1.4

STAR WARS: The Old Republic > English > General Discussion
Developer Update: Shadow Optimizations in Game Update 1.4
First BioWare Post First BioWare Post

Jaisen-Naritus's Avatar


Jaisen-Naritus
10.09.2012 , 09:04 PM | #201
Just chiming in to say that I'm also experiencing some serious issues with 1.4, running only a single GPU (GTX 480). I just resubbed to find that the game is very difficult to play.. My FPS seems fine, but there's this constant micro-stuttering that is just becoming a massive headache while trying to play.
Republic Commando

FeekSands's Avatar


FeekSands
10.12.2012 , 07:30 PM | #202
Patch 1.4.1a has not helped. Graphics are set at lowest quality shadows off. I have GeForce GT 220. Same driver I had before 1.4 patch. Only graphic isssues I have are with this game since patch. Still have choppy graphics. example of non-rendering is the taxi disappears and I am floating along lol.

Khosann's Avatar


Khosann
10.13.2012 , 01:57 PM | #203
Quote: Originally Posted by FeekSands View Post
Patch 1.4.1a has not helped. Graphics are set at lowest quality shadows off. I have GeForce GT 220. Same driver I had before 1.4 patch. Only graphic isssues I have are with this game since patch. Still have choppy graphics. example of non-rendering is the taxi disappears and I am floating along lol.
1) Patch 1.4a solved the stuttering issue for me. But 100%.

When there is a message displayed on the screen (codex entry warning for instance) or when the game renders a new nameplate for the first time, game stutters once. Additional renderings of the same nameplate do not cause repeating stutters. It seems game is checking something for nameplates (a script) and that causes the stutter.

2) Alderaan and other intense tree areas have slow FPS problem.

Nar Shadda and other no foliage have no FPS issues.

I have GTX 580. My FPS in Alderaan is 30 FPS give or take. Before patch 1.4 it was always above 50 FPS.

I think the fake shadows you added to fonts, user interface, loot indication light shafts and character / monster / creature borders are the culprit. It also seems that you removed the optimization for grass / tree 8x supersampling for NVIDIA cards. This causes noticeable frame rate drop.
There is no mistake.

FeekSands's Avatar


FeekSands
10.14.2012 , 07:41 PM | #204
Tried all the patches and trouble shooting I was given by Sutti, in my post. Problems still there. I should have the same performance I had before the patch. What did you do? Also it seems to affect datastream as I can tell for example when running you would hear steady sound, now there is a silent beet every so often. So if you it hour mouse at that moment the game doesn't register you hit your mouse. I would much rather have you roll back the 1.4 patch until fixed then roll it out. So please do not roll out 1.5 until All PERFORMANCE GLITCHES are fixed so you don't introduce more. Some of the glitches are the same as when the game first came out and you fixed those.

Koios's Avatar


Koios
10.14.2012 , 08:36 PM | #205
Quote: Originally Posted by EricMusco View Post
Hello everyone,

Please discuss this week's Developer Update: Shadow Optimizations in Game Update 1.4 blog in this thread!
It took me some time to reply to this because of the issues that this "improvement" brought along...
However, with the latest patch, there is no problem for me anymore on the performance. The shadows, for most areas, look much better.

Since this was one of the reasons that made me stop playing a while back, I am happy to jump back in.

Good fix and good job. (even though, IMO, that should have been at launch).
Squadron 238 - β tester

FeekSands's Avatar


FeekSands
10.16.2012 , 08:25 PM | #206
This shadow update has not fixed the graphic issues I have. The game still stutters, and jumps. The graphics are no longer smooth as they were pre-1.4. Doesn't always recognize when I hit the mouse key. It is like every few beats the game doesn't sample for input so it mini-freezes for a sec then move on, but does this regularly.

Urael's Avatar


Urael
11.06.2012 , 03:36 PM | #207
To the developers of "Shadow Optimizations",

Your "optimizations" are anything but optimizations. Prior to patch 1.4 I could run SWTOR on full high level graphics settings. After patch 1.4 I have to play with shadows and shading on low. The game has lost it's luster visually for me. I have not played since your "quality of life improvement".

In fact, developers of "shadow optimizations", I would like to point out that your "work" has driven me back to your competitor World of Warcraft. After utilizing that product again, I can see that there is much more to do. Perhaps I should thank you for "improving my quality of life" but, then again that "improvement" was gained by leaving your product for a better one.

- Urael

Rogoo's Avatar


Rogoo
01.15.2013 , 11:16 AM | #208
Necro for justice.

Players with high-end AMD CrossFire or Nvidia SLI machines should notice a large improvement when running the game with the new shadow system.

When will AMD Crossfire issues be fixed ? Does Ewen Vowels still work at Bioware ?
You are not your rig specs. You are not your K/D ratio. You are not your character level. You are not your sig.
Gunslinger / Shadow / Sentinel / Powertech
The Hero engine: a 2005 technology bringing 2013 rigs to their knees.