Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Developer Update: Shadow Optimizations in Game Update 1.4

STAR WARS: The Old Republic > English > General Discussion
Developer Update: Shadow Optimizations in Game Update 1.4
First BioWare Post First BioWare Post

Kamansus's Avatar


Kamansus
09.26.2012 , 03:11 PM | #111
I'm also having stuttering issues (when moving/turning mostly) on my SLI'd 2 x GTX 460 graphics cards. Disabling SLI removes the stuttering, as does disabling shadows (even with SLI enabled).

Monitoring GPU usage shows that usage is lowering along with the dropped framerate, so both GPUs are not being properly utilized when moving/turning the camera.

Hope that helps, I'll just play without shadows until this gets figured out.

RSVRichie's Avatar


RSVRichie
09.26.2012 , 03:40 PM | #112
FPS were like a slideshow when i logged in after downloading the patch, all settings maxed, including shadows, which look great by the way.

System is as follows

Phenom II x6 1055t
8GB DDR3 G.Skill Ripjaws
2x HD 6950 2gb Crossfire

The fix for me was to disable crossfire, appears to have fixed the stuttering and all settings maxed is extremely playable, no noticeable FPS dips except in the usual heavy areas of the fleet.

Crossfire was working fine for me before, but now 1 card is disabled the performance for me is better than ever.

MoldyDaBear's Avatar


MoldyDaBear
09.26.2012 , 04:37 PM | #113
http://i214.photobucket.com/albums/c..._26_031250.jpg

this is a picture of my UI after 1.4. i have bad stuttering and i was running on high before the patch, disabling shadows has not helped at all. will try running it in windowed mode to see if that helps, but this is really bad and unplayable as it stands.

Crixa's Avatar


Crixa
09.26.2012 , 05:08 PM | #114
Also getting horrible fps and stuttering since 1.4. Before the patch I was running all settings on high/very high, but after the patch I've tried turning everything off that will go off and the rest to low but still getting a bad stutter which is making the game unplayable especially for pvp.

Currently running a single nvidia gtx 570

MoldyDaBear's Avatar


MoldyDaBear
09.26.2012 , 06:01 PM | #115
tried to go into window mode and all the game does now is crash. i have a brand new Nvidia gtx 630 that worked great before this update and now i cant even run the game.

GuybrushT's Avatar


GuybrushT
09.26.2012 , 07:28 PM | #116
Same exact issues as others have discussed... Here is my dxdiag.txt

Dual 7970s in SLI mode... the flickering stops if I enter fullscreen (windowed) mode

Spoiler

KarathAnno's Avatar


KarathAnno
09.26.2012 , 08:01 PM | #117
I am having the same issue. The game was running fine before 1.4, now I cannot turn the camera without getting headache inducing "skipping". I have tried turning off shadows, turning all graphics settings down to the lowest levels and running windowed, none of that has helped.

Edit: If I am indoors and switch to Windowed (fullscreen) mode it helps. But outdoors it still has the issues.

Spoiler

Glzmo's Avatar


Glzmo
09.26.2012 , 11:18 PM | #118
Quote: Originally Posted by GuybrushT View Post
Same exact issues as others have discussed... Here is my dxdiag.txt

Dual 7970s in SLI mode... the flickering stops if I enter fullscreen (windowed) mode
Just to clarify, you are using CrossfireX, not SLI, as you have AMD cards. And when you switch to Fullscreen (Windowed) mode or windowed mode, CrossfireX is disabled as AMD doesn't support CrossfireX in Windowed mode (Nividia's SLI does work in windowed mode, however). The map/minimap flickering is a CrossfireX issue, so you only see it when it's enabled. This same issue was present during beta but fixed (same goes for the multi-GPU performance issue, by the way). Bioware should check their changes back in beta that fixed all these issues and see if they can re-apply them.

Khosann's Avatar


Khosann
09.27.2012 , 12:36 AM | #119
It could be the new NAMEPLATES system. With 1.4 nameplates have shadows. Some people say that turning them off removes the stuttering issue completely. Please read below and try it. Hope this helps (how this was not posted here lol!)

http://www.swtor.com/community/showthread.php?t=537228

GnatB wrote on Yesterday , 10:28 PM | #10

Quote:
Works wonders for me.

Note: I think it's actually the *creation* of the name plates that is causing the stutter... just that the scaling option causes them to keep needing to be recreated at the new size. Even with scaling off, if I have nameplates on I get get a short "hiccup" of no visual update when I approach the holds on fleet. But once I'm there (and nameplates for crowd is generated) it's fine.

It's why you (mostly) only see this when you turn around/move around. As that causes the nameplates to resize/recreate.

So scaling off dramatically improved it, nameplates off eliminated it.
Also HansBrolo wrote Today , 04:38 AM | #11

Quote: Originally Posted by HansBrolo View Post
You can see that there's something very wrong with the text shadow rendering post-1.4:

http://i.imgur.com/hZt2Z.png

In 1.3, the text shadows were rendered as a 2-3px black outline. In the screenshot above (taken today), you can see that they are distorted and uneven.

I've encountered massive stuttering and hardlocking problems in Flashpoints, and just a general FPS decrease in the open world. Haven't tried turning off the Nameplates... I'll give that a shot.
There is no mistake.

Startmeup's Avatar


Startmeup
09.27.2012 , 12:43 AM | #120
Quote: Originally Posted by AllisonBerryman View Post
Hey everyone - we're aware of some issues introduced in Game Update 1.4 that may cause frame stuttering or performance problems (particularly on CrossFire or SLi setups). If you are experiencing these problems, please try disabling shadows. We are working on resolving these issues, but disabling shadows in the meantime may result in a performance increase. If you notice a performance increase after disabling shadows, please post to let us know (as some of you already have). We'll update you if we have any more information to share as we work on this issue. Thank you!
I turned shadow quality to off - no effect, I have terrible frame stuttering (as seen in the radar window) and movement stuttering making the game unplayable. Turning shadow quality to off and everything else to low doesn't seem to help at all. I have a crossfire 5800 with latest drivers, prior to 1.4 the game ran great.

I turned off nameplates and with shadow quality still off, also with everything else back to "normal" - high settings - the stuttering when moving seems to have gone - the radar stuttering is still present.