Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Not sure if its my video card or the game. need help[

STAR WARS: The Old Republic > English > Customer Service
Not sure if its my video card or the game. need help[
First BioWare Post First BioWare Post

Ditolus's Avatar


Ditolus
09.17.2012 , 11:01 AM | #1
This is weird. i've been running this game perfectly for nine months. all of a sudden 2 days ago i started getting these odd graphical glitches. for example at the character selection screen when u first load up, my character is invisible as is my ship thats supposed to be behind him.. all thats showing are some of the lights and view screens of the ship and then just space. in the actually game whenver i open the character window to look at my gear the entire gaming world dissapaears and im floating in space. i also noticed a huge fps drop on alderaan and in corellia black hole area that i never had before. also the names above npcs and my companion are blurry and unreadable. could this be video card related? im running other games like battelfield 3 which i think is much more graphics intensive than swtor and have no issues. could it be swtor itself? theres not much dust in my comp and i have the latest drivers from nvidia. im running a geforce gtx 570.

Beesodd's Avatar


Beesodd
09.17.2012 , 11:23 AM | #2 This is the last staff post in this thread.  
Hi Ditolus,

It could be a couple of issues, hopefully we can get this fixed for you easily. First of all, can you please try running the repair function on the launcher. This can be found by clicking the cog icon after logging in. When this runs it will search for and repair any damaged files that may be causing this.

Also, have you recent updated your drivers? We have a number of reports of issues with the 306.23 nvidia drivers. Rolling back to 301.42 might help, as these drivers have been reliable for us.

I hope this helps.

Beesodd | BioWare Customer Service - Forum Support