Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Hitching, Stuttering, low FPS

First BioWare Post First BioWare Post

Shredit's Avatar


Shredit
09.04.2012 , 08:21 PM | #1
So first off I want to say that I love this game, and even though it runs terrible on my system I still pay to play it every month. I am hoping that BioWare will reward it's faithfuls with some sort of fix on how this game accsesses our hard drives. If there is anything you think I could tweak or change that may have worked for you on this issue please let me know. But I run 60 FPS in most places except for PvP and on fleet. On fleet my frames will drop as low as 10fps....That being said here is a little bit of information about my system.

Motherboard: Asus Republic of Gamers Crosshair V Formula AM3+
CPU: AMD-FX Bulldozer 8150 (8core) @4.4ghz on water
GPU('s): Two GTX 560 ti special editions in SLI @950mghz
SSD: Two 240gb Corsair Force ssd's
PSU: 1000W Cooler Master modular PSU
RAM: 16gb G.Skill sniper

I am fairly sure the issues I am running into are not hardware, but hey I could be wrong. Like I said, I am getting really frustrated with the low frames please help!

Ratae's Avatar


Ratae
09.04.2012 , 08:39 PM | #2 This is the last staff post in this thread.  
Hello Shredit,

Could I suggest you take the time to read through the following thread, which contains some suggestions from other players for improving FPS rates in game? -
http://www.swtor.com/community/showt...=improving+fps

I hope there might be something in there to help you.
Ratae | BioWare Customer Service - Forum Support

Shredit's Avatar


Shredit
09.05.2012 , 05:40 PM | #3
That would have been a helpful link if I had a 40$ graphics card and a core duo processor that was 8 years old. I gave u my pc specs, it isn't my pc.