Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Black Screen, Computer Crashing, Video Card Running Hot

STAR WARS: The Old Republic > English > Customer Service
Black Screen, Computer Crashing, Video Card Running Hot
First BioWare Post First BioWare Post

Quinlynn's Avatar


Quinlynn
09.04.2012 , 11:25 AM | #1
I had all of the above happening and finally figured out that the stock heat sink and fan on my vid card failed. This is a common issue with newer games that use the GPU more than the CPU, like SWTOR does.

This is my vid card:
http://www.geforce.com/hardware/desk...specifications

This is the after market heat sink and fan that I chose to use:
http://www.newegg.com/Product/Produc...82E16835426026

This is a YouTube video that helped me self install:
http://www.youtube.com/watch?v=NA5prYqTKTY

I was running as hot as 75c idle and over 100c when using SWTOR. The 100c was causing my computer to crash or go to black screen. Since installing the new heat sink / fan, my idle temp is 39c and full load is 50c. Ran SWTOR all weekend with no issues and was happy.

Just wanted to share since I figure this would fix allot of issues for peeps with similar problems.

Sutii's Avatar


Sutii
09.04.2012 , 11:41 AM | #2 This is the last staff post in this thread.  
Hello Quinlynn,

Thank you for sharing that information with the community. Incorrect management of heat and airflow can often be the cause of problems such as this, but I'm glad to hear that you identified the problem, and found a resolution.

If there is anything else that you do require assistance with, please let us know.

Take care and have fun playing Star Wars™: The Old Republic™!
Sutii | BioWare Customer Service - Forum Support