Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

This launcher makes me so fcking angry...

STAR WARS: The Old Republic > English > Community Content
This launcher makes me so fcking angry...

Tseuqreve's Avatar


Tseuqreve
12.13.2011 , 12:05 PM | #1
Love the game.

Hate the launcher.....

Had this same problem when downloading the beta client, it took me a total of 3 days to download it. I was hoping this problem would be fixed by launch, but apparently not, I started the download yesterday, and now 17 hours later I'm not even half way through the patching....

Says I'm downloading at 350+ k/b's yet I'm only progressing by .01 gb every 5 minutes or so??? So *********** dumb. It's like the download speed remains... But it just freezes the download or something, I have no clue.

Anyways, decided to come rant since I had nothing else to do and perhaps other people have this problem or have found a solution etc.. I just think it's one of the stupidest problems I've ever seen for a LAUNCHING game to have, I have gained .02 gb since typing this message, and I'm still only on English Assets 1... So im probably not even half way through.

Imperium
A Guild inspired by the Roman Republic
Website | Guild HQ | Guild Thread

NotThatOne's Avatar


NotThatOne
12.13.2011 , 12:47 PM | #2
Sounds a like a problem with your connection, man, The launcher/patcher worked just fine for me. the download was very fast for such a large series of files. I'd suggest reseting/replacing your router.

Haven't gotten my early access yet, though. So I imagine I'll be waiting until the 18.