Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

A Lead Event Quest Bugged

First BioWare Post First BioWare Post

Nellsterzzz's Avatar


Nellsterzzz
08.15.2012 , 09:28 AM | #1
Because there were too many people trying to do the quest at once, i grouped up with some people to do it. When we got to the part where we dig up the mask i tried to pick up the shovel but it didnt let me and then the timer ran out. I tried going back to the droid but I couldnt access it anymore. So I abandoned the quest like you guys said, now how I am supposed to get it back? That quest was given to us via in game mail. Please if you could help asap

Ogada's Avatar


Ogada
08.15.2012 , 10:32 AM | #2 This is the last staff post in this thread.  
Hi Nellsterzzz,

Please submit an in-game help request with as much detail as possible and our in-game support staff will do what they can to help you.

Thank you for your time and apologies for any inconvenience caused.
Ogada | BioWare Customer Service Forum Support