Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

NodeSpecCache Error

First BioWare Post First BioWare Post

Xxbrandon's Avatar

08.10.2012 , 05:51 PM | #1
i almost always get this error when i try to log in, switch characters or fly somewheres. I have tried the fix launcher and re installing with some success but the error always comes up after an hour or two. I tried deleting the DiskCacheArena file and the DiskCacheStatic file. And i made sure that that launcher as been added to the exceptions on my firewall. Any help with fixing this so it never happens again would be great!

Bronholz's Avatar

08.10.2012 , 06:23 PM | #2 Click here to go to the next staff post in this thread. Next  
Greetings Xxbrandon,

Thanks for reporting this to us.

Please try running the Repair function from the launcher, this will check for and repair any corruptions in your game files. You can find this by logging into the launcher and clicking the cog icon.

This issue can also be caused by having a language other than English (United States) set as the fallback language in your Windows preferences. If you're running Windows 7, this can be set from the 'Region and Language' control panel go to the Administrative tab and make sure the 'Current language for non-Unicode programs' is set as 'English (United States)'. If this is not the case, please try changing this and then running the game again.

Thanks for your patience.
Bronholz | BioWare Customer Service Forum Support

Xxbrandon's Avatar

08.10.2012 , 10:09 PM | #3
i've tried repairing the launcher many times and the language was set to english, I still get the error when i try to change characters or during some loading screens.

Bronholz's Avatar

08.10.2012 , 11:33 PM | #4 This is the last staff post in this thread.  
Thanks for trying that for me Xxbrandon,

There's a few other things that have been known to cause this, which i have listed below.
  • Windows user account name contains extended characters (accented characters, Greek characters, Cyrillic characters etc.). You can try creating a second administrator account using only basic numbers/letters and see if that works.
  • ZoneAlarm Extreme Security 10.x has been known to cause conflict with the game. If you have this installed, could you try turning it off to see if this affects the issue.
Thanks for your patience.
Bronholz | BioWare Customer Service Forum Support

Lenlo's Avatar

08.11.2012 , 12:02 PM | #5
can you make sword in box light sword so sword come out when opened? then if sword is back after sword, use light saber on box, and saber will be boxed after sword is out. - Battlebug
Our brains can't withstand mangled english of that magnitude!

APhantasm's Avatar

08.13.2012 , 10:15 PM | #6
Quote: Originally Posted by Lenlo View Post
Not all the recommendations on that thread work. I tried them all, and in the end it came down to an incompatibility between SWTOR and Kaspersky Pure. I have to disable my antivirus / firewall to play the game, otherwise I get nodespeccache every time I try and load the game.

I'm actually looking at maybe trying to replace Kaspersky Pure in hopes that the new software isn't incompatible with the game.