Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

How To Fix FPS / LAG Issue !! < < < < < <

STAR WARS: The Old Republic > English > PvP
How To Fix FPS / LAG Issue !! < < < < < <

Phixler's Avatar


Phixler
12.21.2011 , 09:23 PM | #51
Quote: Originally Posted by Brzytwa View Post
this is problem on the server side or we talk about different things. ppl have huge problems with skill delays/lags that makes PVP unplayable. I have 50ms latency and when I run to fight my skills have something 1-3s delays after global cooldown.

that product is failure. 6 years of development and that tiny thing like 8 vs 8 matches are unplayable even on "light" servers. that is no excuse for pathetic and lazy dev work with that. I bought this game only for PVP and I saw every other MMO released last 12 years and I have to say this is the worst PVP system and optimisation I've ever seen.


Edit.. look at other MMOs like Rift, Warhammer, AoC, DAoC with their 100 vs 100 matches without any delay and lag and compare it to this crap.
Warhammer had massive lag for the first year of it's launch, they had to remove fortresses because the game couldn't handle so many people in one place.

In all honesty the only reason there isn't lag in WAR now is because there are like 500 people playing it.

DropDeadFred's Avatar


DropDeadFred
12.21.2011 , 10:24 PM | #52
Quote: Originally Posted by carrylot View Post
Ya I totally want to go spend 600 dollars so I can run this game at 60 fps. Amazing idea bro, maybe we should do that for every game? Some of us have lives and don't feel like upgrading for each new game, the developers should build the game around mid PC specs so that the majority of players get 60 fps. Not the top 10 percent of you.
I built my p 6 years ago and spent 350 bucks on GFX card and ssd's and
I have 30+ fps in heavy pvp!

Swtor is easy to run.
My friend plays on a piece of crap.

Partyrockk's Avatar


Partyrockk
12.22.2011 , 01:45 AM | #53
I'm running on a machine that can handle any game out there on ultra high (yes, even Crysis). I was getting unplayable mouse/graphic lag until I turned shadows off. Now everything is on high, and all is well. Just no shadows.

Clearly a bug.

notoriious's Avatar


notoriious
12.22.2011 , 07:58 PM | #54
Quote: Originally Posted by Neeseek View Post
Yeah, Let's all blame the Devs on their first MMORPG ever, and they're bugs/memory leaks at launch


Whiny Kids, you didn't play WoW at launch did you?


Anyways, I have the Phenom II6 also @ 2.8 GHZ

5770 1GB

Nothing special, I get 40-60 FPS while questing, 25 in WZ.

No idea if that's what I should be getting.
ive played wow for about 5 years now, and they have had alot of glitched and lag problems which still occur now, no 1 mmo will ever be without lag problems, glitches etc. people just feel the need to complain as there expectations were too high for the 1st ea MMO

enslavr's Avatar


enslavr
12.22.2011 , 08:24 PM | #55
Thanks for the advice. I didnt even know there was an "off" button. My game is much smoother now after i turned it off.

however the "latency" that people experience is obviously still there. I really hope they fix it because its fairly annoying.

on the bright side everyone seems to be experiencing it so its probably not that bad but it still a pain.

SnakeBites's Avatar


SnakeBites
12.22.2011 , 09:21 PM | #56
Intel i7-2600k Quad Core
8GB DDR3 1600MHz
2GB AMD RADEON HD6970

I built this PC to play Battlefield 3 on high settings. I get 60+ frames.
In SWTOR warzones i get 35 frames, sometimes lower.
Explain that one to me.

Rongxin's Avatar


Rongxin
12.23.2011 , 05:30 AM | #57
I'm getting terrible FPS even with everything set to low.

I blame the game-engine not supporting multi-threading

JASskaters's Avatar


JASskaters
12.23.2011 , 03:01 PM | #58
PLEASE FIX!!!!!!! EVERYTHING RUNS GREAT, BUT THE SECOND I STEP INTO ANY BUILDING I LAG LIKE A MOFO!!!!! THIS IS EXTREMELY ANGERING BECAUSE MANY BIG MISSIONS TAKE PLACE INSIDE BUILDINGS AND I CANT MOVE ON BECAUSE OF F-LAG!!!!!!!! once fixed its fine! good game besides lag

AdrianStarstride's Avatar


AdrianStarstride
12.23.2011 , 03:11 PM | #59
I have the same issue, I run the game flawlessly on my 2500 dollar laptop and play many other games without a bit of lag. However as soon as I get into the warzones I lag so bad that I have 3-5 second delays on any ability I use making pvp incrediably frustrating. I'm very upset with this being that I bought the game primarily to pvp. All I am requesting is for this issue to be dealt with since obviously a decent number Of people are having the same issues. It's 100% server/game design not my comp

Sarlacc_Enforcer's Avatar


Sarlacc_Enforcer
12.23.2011 , 03:18 PM | #60
Quote: Originally Posted by Hedzlol View Post
Well this is for MOST people!
Feel free to post here if it worked, It did for me

http://i39.tinypic.com/2emmkp1.jpg

^ Shadow Quality: OFF
Saw the title of the thread, hoping it would be an in-depth guide.

But, it's this.

My computer is decent. 6GB RAM and some $100+ ATI graphics card. All my settings are turned down and I evened lowered my resolution ridiculously. Yet, in Warzones, my framerate ranges between 10-20FPS. It's not like this out of Warzones. Clearly, it's not my issue, but Bioware's.
Sarlacc Enforcer
It's Not A Joke