Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Failed to initialize web browser

STAR WARS: The Old Republic > English > Customer Service
Failed to initialize web browser
First BioWare Post First BioWare Post

Crimson_Paladin's Avatar


Crimson_Paladin
07.10.2012 , 08:16 PM | #1
I've not heard of others having this problem, so I'm a bit confused. When I try to open the launcher, it gives an error message saying "Failed to initialize web browser". I tried to run FixLauncher but it says it had an error opening launcher.exe and libsef.dll for writing and didn't do anything.

I installed some Windows updates today, before trying to play, so I don't know if they're to blame or if the update is to blame, or something else. What could be causing this problem?

Beesodd's Avatar


Beesodd
07.10.2012 , 08:19 PM | #2 Click here to go to the next staff post in this thread. Next  
Hi Crimson_Paladin,

This is quite an unusual error message. Please download the installer (from here) and run it over your existing install.

It won't reinstall the game from scratch, but just replace any damaged files which may be causing this issue.

Please let us know how if this helps.

Beesodd | BioWare Customer Service - Forum Support| Find help for all EA Games at Answer HQ.

Crimson_Paladin's Avatar


Crimson_Paladin
07.10.2012 , 08:50 PM | #3
Thanks. Here's what happened: I did as you said. When I tried to open the launcher again, it gave a "failed to update host" message. Fixlauncher was unable to rewrite libsef.dll for some reason at the time. From there I found a thread on that and followed the instructions, rebooting the computer and deleting launcher.settings. I then ran Fixlauncher and it managed to write libsef.dll. The game started to work again. Thanks for the help!

Beesodd's Avatar


Beesodd
07.10.2012 , 08:53 PM | #4 Click here to go to the next staff post in this thread. Next  
That's good to hear, and thank you for getting back to us.

Have fun!

Beesodd | BioWare Customer Service - Forum Support| Find help for all EA Games at Answer HQ.

salteggerh's Avatar


salteggerh
07.11.2012 , 12:53 AM | #5
Okay so I'm having this same problem. It said failed to initialize web browser so i tried what crimson paladin did and the launcher actually launched to where I could put my email and password in and stuff. But then the launcher started to get updated then the it just closed out. I tried to launch it again but it yet again, failed to initialize web browser. And i don't have a launcher.settings file anymore.... Can someone please help?

salteggerh's Avatar


salteggerh
07.11.2012 , 12:57 AM | #6
Well nevermind. I just re-ran the launcher fix and it finally worked this time around. I don't know why it wouldn't before. Sorry for the unnecessary post.

AtreusVarus's Avatar


AtreusVarus
09.06.2012 , 10:20 PM | #7
Can you explain step by step what you did to fix it? having this issue as well

Bronholz's Avatar


Bronholz
09.06.2012 , 11:06 PM | #8 This is the last staff post in this thread.  
Greetings AtreusVarus,

Which of the issues are you encountering?

If you have not already please try the steps that have been suggested by my colleague earlier in the thread.

Thanks for your patience.
Bronholz | BioWare Customer Service Forum Support

chunkchest's Avatar


chunkchest
04.22.2013 , 01:19 AM | #9
I am having this same problem except re-installing isnt working, i cant even load the game client to repair or anything like that

OwenBrooks's Avatar


OwenBrooks
04.22.2013 , 01:55 AM | #10
Give this a try http://www.swtor.com/community/showp...71&postcount=2 it should fix your issue

libcef is part of the chromium files and is installed by a lot of games.