Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Sorry, you cannot refer this email address.

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Sorry, you cannot refer this email address.
First BioWare Post First BioWare Post

Naugor's Avatar

07.11.2012 , 03:35 AM | #31 Click here to go to the next staff post in this thread. Next  
Greetings everyone,

We are still investigating the cause, thank you for your continued updates. As soon as we have more information available, we will let you know.

Thank you for your patience.
Naugor | BioWare Customer Service - Forum Support | Find help for all EA Games at Answers HQ.

Epso's Avatar

07.11.2012 , 04:25 AM | #32
Ive got the same issue today with sending Refer a Friend invite to my friend who live in russia. The target email is "" which has never had EA/Origin account linked and never received Beta invite or had anything to do with Swtor.
Iam looking forward to invite my friend. Thanks for looking into it and i hope this information helped also.

Gabrandt's Avatar

07.11.2012 , 06:12 AM | #33
Quote: Originally Posted by Sickith View Post
I think the issue relates to "free email services" such as hotmail, ymail, gmail etc... because when i tried none of those worked and was never signed up to any EA accounts. I then tried my university email address and it worked.
Well, I've been unable to invite anyone with hotmail, but Yahoo has worked fine so far.
Shameless linking of my referral link. Click it to give us both free stuff (You get 1 weeks free subscribtion, Cartel Market Unlocks and 1 Server Transfer!).

Pairaka's Avatar

07.11.2012 , 06:25 AM | #34
Having the same issue. I tried having one of them do the EA account thing (the other doesn't have an EA account) and got the same results: "You cannot refer this email address."
Mera Virai | "You should be running..."

Brewski's Avatar

07.11.2012 , 08:15 AM | #35
Getting the same issue on 6 out of 12 invites. There doesn't seem to be any consistency in terms of the address domain, as I have one each of both yahoo and gmail that worked, and another of each that failed.

If it truly is caused by the email address in question having opted out of emails, or already having an invite/account, it would be nice to see that message returned instead of the generic error we get now. If it said "Sorry, that email address already has an active account." or "Sorry, that email address has opted out of receiving mail from EA." I would know how to proceed.

Inspirator's Avatar

07.11.2012 , 08:41 AM | #36
Have you guys tried referring to the same email address repeatedly? If not, I would because this sounds a lot like it may be the only error message set up and so it also displays when the request just doesn't go through for something like the referal server being overloaded or not immediately able to connect to the destination mail server.

Kaalkingdom's Avatar

07.11.2012 , 10:53 AM | #37
Will the resolution be posted to this thread?
Kaeli - OTG - Empire Chapter Leader
"Laid back, not so serious, no drama. All about the fun!"
Carla, host of Corellian Run Radio

thesmileguy's Avatar

07.11.2012 , 12:57 PM | #38
Quote: Originally Posted by Tirvaak View Post
Hi thesmilerguy,

If you wish you can subscribe to this thread. I will update it once we have more details on this problem.

Thanks! I appreciate that you guys are working on this. The sooner it's fixed, the sooner my friends can start playing (and hopefully subscribing!)

Quote: Originally Posted by Kaalkingdom View Post
Will the resolution be posted to this thread?
It seems so based on their response above. I would sub to this thread.

Tyrogenic's Avatar

07.11.2012 , 04:45 PM | #39
Any news to this? Had the problem for a long time now...
"We all take risks."
―Kit Fisto

Sir-Coffee's Avatar

07.11.2012 , 11:59 PM | #40
Please fix this issue.