Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Launcher doesn't work

First BioWare Post First BioWare Post

Azikj's Avatar


Azikj
07.10.2012 , 08:16 AM | #1
Hi. I've been having problem logging in to game. After today's patch (July 10th) launcher won't even show login window - it just shows info saying "Unable to load application information". Please help!

Axolipher's Avatar


Axolipher
07.10.2012 , 08:18 AM | #2 Click here to go to the next staff post in this thread. Next  
Greetings Azikj,

I would like to ask that you run a "fix launcher" program to see if this fixes the issue. You should be able to find the fixlauncher.exe program if you navigate to your "Star Wars - The Old Republic" directory. The default location of this is:
Windows 32 Bit: C:\Program Files\Electronic Arts\BioWare
Windows 64 Bit: C:\Program Files (x86)\Electronic Arts\BioWare
If this file does not exist in your swtor directory then you will need to reinstall the launcher client from here.

After this is done please report back with the results so we can assist further if needed.

Thank you!

Axolipher | BioWare Customer Service - Forum Support

mastabenja's Avatar


mastabenja
07.10.2012 , 08:33 AM | #3
hey there.

I have the same Problem with my launcher after todays patch.

I reinstalled it with the Link posted by you and its the same over and over again...

I start the Launcher, it trys to update the launcher, then the Launcher shuts down and nothing happens.
If i try to start it again, i can see it in the taskmanager Prozessmonitor (but not on the desktop or somewehre else) for like 3 sec and then it just shuts down and nothig happens.
Dont tell me to use the FixLauncher.exe... it doesnt work (and it did never work for me)... it just runs to ~75% and then shuts down it self and nothing happens...

Edit: i closed all other programms as wel as firewall and antivir

here is my log:

Code:
20120710162540 INFO   -----------------------------(-120)-----------------------------
20120710162541 INFO   SpecsHash=95695708.3953780328
20120710162541 INFO   Starting patcher patch
20120710162541 INFO   ManifestState=GetManifest: , current=-1/upcoming=0/required=0
20120710162541 INFO   Download: http://manifest.swtor.com/patch/patcher.patchmanifest
20120710162542 INFO   Patch manifest state is unknown.
20120710162542 INFO   Delete C:/Program Files (x86)/Electronic Arts/BioWare/Star Wars - The Old Republic/patcher.version, and try again.
20120710162542 INFO   ManifestState=GetManifest: , current=-1/upcoming=0/required=0
20120710162542 ERROR  ManifestComplete:patcher/http://manifest.swtor.com/patch/patcher.patchmanifest
20120710162542 ERROR  Fetch Manifest Failure: VersionFail
20120710162543 INFO   Manifest Loaded: patcher, current=-1/upcoming=-1/required=59
20120710162543 INFO   ManifestState=Download: patcher, current=-1/upcoming=-1/required=59
20120710162543 INFO   Download: http://127.0.0.1:56454/app/download.solidconfig
20120710162543 INFO   Download: http://cdn-patch.swtor.com/patch/patcher/patcher_-1to59.solidpkg
20120710162543 ERROR  Going Offline
20120710162543 INFO   Download Creating: http://cdn-patch.swtor.com/patch/patcher/patcher_-1to59.solidpkg
20120710162543 INFO   Download: http://cdn-patch.swtor.com/patch/patcher/patcher_-1to59/patcher_-1to59.z01
20120710162543 INFO   Download Downloading: http://cdn-patch.swtor.com/patch/patcher/patcher_-1to59.solidpkg
20120710162543 INFO   Patching group: patcher -1->59
20120710162543 ERROR  unknown group (patcher)
20120710162543 INFO   Patching file:  patcher -1->59
20120710162543 INFO   Recognized patcher version 0
20120710162555 INFO   Download: http://192.168.178.1:49000/igddesc.xml
20120710162555 INFO   Download: http://192.168.178.1:49000/any.xml
20120710162555 INFO   Download: http://192.168.178.1:49000/igdicfgSCPD.xml
20120710162556 INFO   Download: http://192.168.178.1:49000/igddslSCPD.xml
20120710162556 INFO   Download: http://192.168.178.1:49000/igdconnSCPD.xml
20120710162608 INFO   Download: http://cdn-patch.swtor.com/patch/patcher/patcher_-1to59/patcher_-1to59.zip
20120710162609 INFO   Download Complete: Complete: http://cdn-patch.swtor.com/patch/patcher/patcher_-1to59.solidpkg
20120710162609 INFO   ManifestState=Patch: patcher, current=-1/upcoming=-1/required=59
20120710162609 INFO   Download Seed: Seeding: http://cdn-patch.swtor.com/patch/patcher/patcher_-1to59.solidpkg
20120710162611 INFO   Closed launcher

Azikj's Avatar


Azikj
07.10.2012 , 08:37 AM | #4
Quote: Originally Posted by Axolipher View Post
Greetings Azikj,

I would like to ask that you run a "fix launcher" program to see if this fixes the issue. You should be able to find the fixlauncher.exe program if you navigate to your "Star Wars - The Old Republic" directory. The default location of this is:
Windows 32 Bit: C:\Program Files\Electronic Arts\BioWare
Windows 64 Bit: C:\Program Files (x86)\Electronic Arts\BioWare
If this file does not exist in your swtor directory then you will need to reinstall the launcher client from here.

After this is done please report back with the results so we can assist further if needed.

Thank you!
Hi. I've tried to run fixlauncher, it did restored previous files, but when i try to run launcher itself, it show the same message. i also downloaded the launcher client and when i tried to run launcher, it immediatly downloads updates for the launcher, then shows "unable to load configuration". I even did not typed my login. So the problem still remains.

Avinchi's Avatar


Avinchi
07.10.2012 , 08:40 AM | #5
same error here ( i posted my log in previous post) try changing language in setup ( it started dling the patch) unfortunetly it crashed on installing. Try it perhaps it will work for you

OldTyndareos's Avatar


OldTyndareos
07.10.2012 , 08:42 AM | #6
It would seem Im suffering the same issue. I used the fix launcher utility. Nothing changed. Used the utility after changing the name of the launcher icon to launcherabc so it would generate another. Nothing changed. Re-downloaded set up as was directed. Looked like it worked, as the log in screen popped up, only for it to try to update and go right back to the same issue. Tried it a couple of times, same thing happens. Any other suggestions?

Lacras's Avatar


Lacras
07.10.2012 , 08:47 AM | #7
i'm having a similar problem. my client downloaded the patch fine. but when i clicked play it came up with an error saying "was not able to launch the game (1)" i've tried the repair function and it get's stuck on 99% and freezes. i don't know what to do

Blackthorne's Avatar


Blackthorne
07.10.2012 , 08:50 AM | #8
downloaded the patch fine.... could even start it up this morning, though none of the servers were online, then after maintenance the launcher says "Login service currently unavailable" and it freezes on me
There is no light- or dark side.... there is only The Force

IcedLance's Avatar


IcedLance
07.10.2012 , 08:55 AM | #9
Quote: Originally Posted by Blackthorne View Post
downloaded the patch fine.... could even start it up this morning, though none of the servers were online, then after maintenance the launcher says "Login service currently unavailable" and it freezes on me
Have same error, launcher states that login servers are unavailable and if i try to close it it freezes.
Here's the log:
Code:
2012-07-10 18:49:37 INFO   File info: launcher.exe size=2513328, created=6/18/2012 17:36:2, accessed=7/2/2012 22:15:0, written=6/18/2012 17:36:2
2012-07-10 18:49:37 ERROR  Failed to load bundles
2012-07-10 18:49:37 ERROR  Going Offline
2012-07-10 18:49:37 INFO   -----------------------------(-240)-----------------------------
2012-07-10 18:49:38 INFO   SpecsHash=0.0
2012-07-10 18:49:39 INFO   Starting patcher patch
2012-07-10 18:49:39 ERROR  JavaScript Error: Uncaught ReferenceError: patchManager is not defined
URL: http://127.0.0.1:59230/app/src/model/patching.js
Line Number: 1
2012-07-10 18:49:56 INFO   User presses exit - E:(true,The login service is currently unavailable.  Please visit our <a href="http://www.swtor.com/community/">forums</a> for the latest updates on the status of this service.) NE:(false,Network error. Check your internet connection)

Lacras's Avatar


Lacras
07.10.2012 , 08:56 AM | #10
i think my problem might have something to do with the launcher update with this patch as it was working fine before and i've tried the fix launcher.exe and as soon as i start the launcher up again it downloads the launcher update and will not work after