Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Mission skills bug?


jimbocolorado's Avatar


jimbocolorado
06.30.2012 , 03:53 PM | #1
After this recent patch I noticed something I reported as a bug but I thought i would post this as well. Before if you had a learned mission discovery in your mission list, or you tried to learn another while a companion was on that mission, you would get a message to that effect and only one can be active at a time. Last night and today, I noticed that now you read the mission and don't get a message and it appears to be used so it is lost!.

I generally buy many mission discoveries for all my alts and then just read as many as i can, unfortunately now they are lost if you already know it and therefore i lost out on some credits. With so many different missions and having several perhaps doing said missions its hard to keep track to not lose them. The message safeguard was good and the missions weren't lost

I hope this can be fixed soon!

GreenSynapse's Avatar


GreenSynapse
07.01.2012 , 07:12 AM | #2
I can confirm this bug still exists and has not been fixed by recent patches. If you have already learned a mission and it hasn't been completed when you read the new mission it just goes poof. It doesn't even tell you the name of the mission you just vaporized.

Since the missions don't give their names until you read them it is difficult to know whether the one you are reading is active unless you have done it enough that you have memorized the icons for that mission level and type. Some of the missions are quite pricey so do use caution.

jimbocolorado's Avatar


jimbocolorado
07.01.2012 , 08:40 AM | #3
I have never noticed this until after 1.3 came out and I am not sure but might even be the last patch on Friday. It is annoying as I probably lost maybe 10 crew missions before i realized what was happening. I initially thought the lack of a notification that I already knew the mission was lot in the fleet lag until i saw the actual mission disapear.

asbalana's Avatar


asbalana
07.01.2012 , 08:52 AM | #4
Indeed true.

I thought, silly me, that I had read that the inability to run the same mission on two alts had been changed in 1.3 and tried it. The second click of a learned mission just disappears without message.

jimbocolorado's Avatar


jimbocolorado
07.02.2012 , 06:51 AM | #5
Anyone have any idea if this is on the radar for a possible fix? I don't remember seeing is on the known issues list.

Thanks

Glower's Avatar


Glower
07.02.2012 , 07:50 AM | #6
Same here.
Bio, fix it please...

jimbocolorado's Avatar


jimbocolorado
07.03.2012 , 06:54 AM | #7
As an update to this issue, I received an email from CS that states that they are now aware and investigating this issue. No known time frame for resolution.
I would recommend that just be slow and cautious when learning skill mission. No more batch learning for a while. Foe me as long as I take my time so i don't lose any expensive missions I'm ok for a bit while they track it down

Zaemiel's Avatar


Zaemiel
07.03.2012 , 07:12 AM | #8
Confrim! =( Still broken...
Please, Bioware, can you create a free PvP and PvE space battle please! Swoop racing is also welcome!

DeathStepper's Avatar


DeathStepper
07.05.2012 , 06:26 AM | #9
Wishing i had read this BEFORE i blew 3 level 340 missions by doubling up.

Glower's Avatar


Glower
08.15.2012 , 01:22 PM | #10
Bioware! Fix it please!!!
SWTOR goes F2P: http://i.imgur.com/1962X.jpg
A: "They’d love to do that at some point, but technically very challenging and unlikely to happen in the near future." (c)
PvP FAQ, A: "We have no plans at this time" (c)