Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Mouse Sensitivity : Smoothing / Acceleration

STAR WARS: The Old Republic > English > General Discussion
Mouse Sensitivity : Smoothing / Acceleration

alderdale's Avatar


alderdale
03.19.2012 , 11:04 PM | #11
Quote: Originally Posted by JaggedOne View Post
I don't have any mouse lag, I can completely rotate my character 360 degrees in both directions, and it is very smooth and steady. And this is with a 3-yr old mouse that is about worn out. I have everything cranked to max in Graphics, incl. Bloom turned on. I get 110 FPS most places, and 85-90 in Fleet. So it isn't the game, my friends
You, see my above post, dont post about something you cant notice as if it doesnt exist. Some people are color blind it doesnt mean theres a lack of color in the world. The level of mouse lag in the game even after game and windows tweaks is still unacceptable to some.

grezgorz's Avatar


grezgorz
04.02.2012 , 01:12 PM | #12
Quote: Originally Posted by JaggedOne View Post
I don't have any mouse lag, I can completely rotate my character 360 degrees in both directions, and it is very smooth and steady. And this is with a 3-yr old mouse that is about worn out. I have everything cranked to max in Graphics, incl. Bloom turned on. I get 110 FPS most places, and 85-90 in Fleet. So it isn't the game, my friends
The issue is NOT mouse lag or low fps, it is that the game engine forces mouse acceleration with no option to disable it. I understand a lot of people don't care or don't notice, but for me and others it is extremely noticeable and annoying. All we're asking is a check box in the preferences to turn off mouse acceleration.

A simple test for those who doubt me:

-Take note of the direction your character is facing and where your mouse is on your mouse surface.
-Quickly snap your mouse to the left, and then slowly return it back to it's starting position
-Do this several times, and you will see that your character is gradually facing further and further to the left each time, even though your mouse is returning to the same starting position

See? That means that mouse acceleration is enabled in the game engine with no option to disable it.

Nepumuk's Avatar


Nepumuk
04.22.2012 , 04:15 AM | #13
Mouse acceleration seems to have gotten worse since patch 1.2.

For current hardware, mouse acceleration is a legacy feature, even for the desktop (Windows), so it should never be enabled for games by default. I still have a switch on my mouse software for turning acceleration off for Windows, but it does not seem to affect SWTOR.

Please turn it off or add an option. Being able to alter this setting at least per INI file would be sufficient.

My camera settings
Smart Camera OFF
Pivot Camera OFF
Camera Rotation Speed 0%

Average game performance
FPS: 70-110
Server Lag: 39-45ms

System
Mouse: Razer DeathAdder, Driver: 3.05, Firmware: 2.45
OS: Windows 7 64 bit
/cjoin LFG on The Red Eclipse

dunkelkind's Avatar


dunkelkind
04.28.2012 , 09:08 AM | #14
This post has been going on for awhile...still no fix and no acknowledgement in the known issues.

http://www.swtor.com/community/showthread.php?t=62987

LordbishopX's Avatar


LordbishopX
05.08.2012 , 12:31 PM | #15
Quote: Originally Posted by Nepumuk View Post
Mouse acceleration seems to have gotten worse since patch 1.2.

For current hardware, mouse acceleration is a legacy feature, even for the desktop (Windows), so it should never be enabled for games by default. I still have a switch on my mouse software for turning acceleration off for Windows, but it does not seem to affect SWTOR.

Please turn it off or add an option. Being able to alter this setting at least per INI file would be sufficient.

My camera settings
Smart Camera OFF
Pivot Camera OFF
Camera Rotation Speed 0%

Average game performance
FPS: 70-110
Server Lag: 39-45ms

System
Mouse: Razer DeathAdder, Driver: 3.05, Firmware: 2.45
OS: Windows 7 64 bit
Gonna try this tonight....
▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀}╠╬[<BishopX>]╬╣{▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀

cs_Kimmo's Avatar


cs_Kimmo
05.08.2012 , 01:03 PM | #16
Enable raw mouse input.

/thread

LordbishopX's Avatar


LordbishopX
05.09.2012 , 10:41 AM | #17
Quote: Originally Posted by cs_Kimmo View Post
Enable raw mouse input.

/thread
Doe the game have a way to set that if so how?
▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀}╠╬[<BishopX>]╬╣{▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀

Semitote's Avatar


Semitote
05.09.2012 , 10:44 AM | #18
I only get the mouse lag when I have bloom or anti-aliasing turned on in-game.

Bloom seems a bit unnecessary - just makes things glow.. It's okay, but I think the game looks less cartoony without it. And the in-game anti-aliasing I haven't found useful at all.
Semee - Legacy 39 - Valor 83 - Social VIII - Juggernaut
The Fatman Nerf Dialogue World #1 8M Empire
"Once you realize what a joke everything is, being the Comedian is the only thing that makes sense."

LordbishopX's Avatar


LordbishopX
05.09.2012 , 12:56 PM | #19
Quote: Originally Posted by Semitote View Post
I only get the mouse lag when I have bloom or anti-aliasing turned on in-game.

Bloom seems a bit unnecessary - just makes things glow.. It's okay, but I think the game looks less cartoony without it. And the in-game anti-aliasing I haven't found useful at all.
I will try anything lol okay time for these to go off thanks....
▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀}╠╬[<BishopX>]╬╣{▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀

LordbishopX's Avatar


LordbishopX
05.11.2012 , 08:46 AM | #20
Quote: Originally Posted by LordbishopX View Post
I will try anything lol okay time for these to go off thanks....
Okay seems better after messing with my graphics setting >.> at least last night it wasn't always sticking in place while trying to move with the mouse weird....
▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀}╠╬[<BishopX>]╬╣{▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀