Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Is it my laptop

SAjames's Avatar


SAjames
06.27.2012 , 06:26 AM | #1
Hi people

i know there are a lot of posts talking about how bad fps and lag are, but after doing almost everything i can do to help improve my performance, nothing has really helped, even got game booster. now the game ran ok when i was on a dead server, but once i moved it all went to hell. and afer yesterdays patch i am now getting screen tearing all over the place, so i need to know if its my pc or the game.

Specs:
Microsoft vista 32-bit
AMD turion x2 dual-core rm-74
4gb ram
ATI mobility Radeon HG 4500/5100

and if it helps my DxDiag:

Spoiler


any advice would be appreciated, and again sorry for creating another of these posts

Dartril's Avatar


Dartril
06.27.2012 , 06:30 AM | #2
Quote: Originally Posted by SAjames View Post
Hi people

i know there are a lot of posts talking about how bad fps and lag are, but after doing almost everything i can do to help improve my performance, nothing has really helped, even got game booster. now the game ran ok when i was on a dead server, but once i moved it all went to hell. and afer yesterdays patch i am now getting screen tearing all over the place, so i need to know if its my pc or the game.

Specs:
Microsoft vista 32-bit
AMD turion x2 dual-core rm-74
4gb ram
ATI mobility Radeon HG 4500/5100

and if it helps my DxDiag:

Spoiler


any advice would be appreciated, and again sorry for creating another of these posts
congrats on getting the patch installed. i highly doubt it's your computer. a lot of people have been getting problems much worse that just graphical glitches, many are getting blue screens, the patch won't install for others and some aren't even getting past the launcher into the game once it is. be patient and we'll work through this together

SAjames's Avatar


SAjames
06.27.2012 , 06:39 AM | #3
yeah i noticed that when i tried installing swtor on my home desktop and the launcher wont install the patch, but still wondering if there might be something i can do.

Dartril's Avatar


Dartril
06.27.2012 , 06:40 AM | #4
Quote: Originally Posted by SAjames View Post
yeah i noticed that when i tried installing swtor on my home desktop and the launcher wont install the patch, but still wondering if there might be something i can do.
after rummaging through the many threads about this, no one seems to have come up with an final solution yet

SAjames's Avatar


SAjames
06.27.2012 , 06:58 AM | #5
Well finally got the game working on my home desktop, and it performs better, but has worse specs :/ so very confused might just reinstall the game and hope for the best

SAjames's Avatar


SAjames
06.27.2012 , 01:54 PM | #6
Ok i got my fps sorted, kinda, basiclly just reinstalled the game, but i am still getting screen tearing (or whatever its called) on both my laptop and my desktop. i have tried,v-sync off-on, aa off-on, changing resolution, changing to window mode back to fullscreen and nothing seems to sort it out, anytips ?

SAjames's Avatar


SAjames
07.01.2012 , 06:29 AM | #7
bump.