Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Website in French?

First BioWare Post First BioWare Post

Ludwig_VanCover's Avatar


Ludwig_VanCover
06.15.2012 , 08:25 AM | #1
I logged on to SWTOR.com today and suddenly everything is in french! I've deleted my cache and it is still in french (atleast I think it is french - it could be German?). Here is a screenshot of what I am experiencing all over the website and forums (the image is kind of long - it has 3 screenshots of this issue around the site) - http://img855.imageshack.us/img855/908/frenchl.jpg

I have made sure that I am in English via the EN button at top, even though I have never clicked on any other lanugage before.
SWTORApps.com - Character Armory and More | Guild: The Army of Light

Enjoy a FREE 7 day Subscription, character transfer, and free goodies mailed to all your characters - click here (Referral)

Ludwig_VanCover's Avatar


Ludwig_VanCover
06.15.2012 , 08:28 AM | #2
An addition - I would select Edit on my post but I cannot read the buttons
This is what displayed after I posted - http://img521.imageshack.us/img521/9088/post2r.png
SWTORApps.com - Character Armory and More | Guild: The Army of Light

Enjoy a FREE 7 day Subscription, character transfer, and free goodies mailed to all your characters - click here (Referral)

LucasEighty's Avatar


LucasEighty
06.15.2012 , 08:31 AM | #3
this happens to me all the time along with glitch that randoms logs you out

dodgey imo

Beesodd's Avatar


Beesodd
06.15.2012 , 08:32 AM | #4 Click here to go to the next staff post in this thread. Next  
Hi Ludwig_VanCover,

Does toggling to French(or German) and back again help? Please try pressing Ctrl & f5 a few times, as sometimes multiple presses are needed.

Does the issue exist after relogging or in another browser?

Thanks.

Beesodd | BioWare Customer Service - Forum Support| Find help for all EA Games at Answer HQ.

Ludwig_VanCover's Avatar


Ludwig_VanCover
06.15.2012 , 08:37 AM | #5
Quote: Originally Posted by Beesodd View Post
Hi Ludwig_VanCover,

Does toggling to French(or German) and back again help? Please try pressing Ctrl & f5 a few times, as sometimes multiple presses are needed.

Does the issue exist after relogging or in another browser?

Thanks.
Whoops, accidently clicked on Repot before I found quote.

I refreshed the page with Ctrl+F5 a few times and also tried toggling between the DE/FR versions. What seemed to work was logging in/out, which is odd.

Anyways, thank you for your timely response!
SWTORApps.com - Character Armory and More | Guild: The Army of Light

Enjoy a FREE 7 day Subscription, character transfer, and free goodies mailed to all your characters - click here (Referral)

Beesodd's Avatar


Beesodd
06.15.2012 , 08:39 AM | #6 This is the last staff post in this thread.  
Ah, thanks for letting me know that your issue was solved with a relog.

If you have any further issues in future, don't hesitate to contact us again.

Beesodd | BioWare Customer Service - Forum Support| Find help for all EA Games at Answer HQ.