Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Ship Models

Dark_Lord_of_Pie's Avatar


Dark_Lord_of_Pie
06.03.2012 , 06:37 AM | #1
Every now and then I have a little tinker on Blender model maker. Naturally, recently the models I wanted to make were from SWTOR.

Jumped right in to the Smuggler freighter (my beloved Opal Moon). An interesting model, as although it was relatively easy, with simple geometric squares and hexagons that were easy to model (I do NOT like doing curves), it's design is asymmetrical giving it a weird perspective. Had to work from screen images and whatever I could google. No blueprint or plans made it interesting.

The colouring and texture is a little customised from the game. I wanted to give her more of the traditional Star Wars Beaten Metal look, like she'd flown out of a junkpile.

The next I attempted was the Republic frigate, or the Esseles model. This was a piece of cake to model as the ship is almost totally symmetrical, and screen shots give a clear profile for base modeling. The tricky part was the colouring of the textures, to give it the Republic paintwork design as best as I could get. But I think it turned out pretty well.

My next target is the Imperial Star Destroyer. Although it's a simple delta shape, and plenty of reference material available, I'm planning on going large scale with that baby, which in the arse-backward world of modelling means the larger the model, the smaller the detail.

Thought I'd share these images to other fans of the game, and if there are any other modellers out there, I'd be interested in seeing your work. [Also, I'm by no means an expert in Blender, or modelling in general, so I'd appreciate any constructive tips others might know; especially on colour modifications and painting textures.]

Thanks for popping by

Dark_Lord_of_Pie's Avatar


Dark_Lord_of_Pie
06.03.2012 , 07:08 AM | #2
Great

The links not working for my images.

Bang goes that idea

Lawrichai's Avatar


Lawrichai
06.03.2012 , 07:39 AM | #3
Where are your images from?

Maybe you just don't have the right link.
Try right clicking on your picture, chose " view image info" and copy paste that selected line.
That usually works