Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Mouse and Keyboard Bugged - Keyboard revents to all caps and mouse buttons stop worki

STAR WARS: The Old Republic > English > Customer Service
Mouse and Keyboard Bugged - Keyboard revents to all caps and mouse buttons stop worki
First BioWare Post First BioWare Post

Shep_Kennelly's Avatar


Shep_Kennelly
05.28.2012 , 02:39 PM | #1
Hello all.

I currently use Razer Black Widow Ultimate Keyboard and Razer Mamba Mouse. I have been playing SWTOR since launch with no problems at all. However, since yesterday (Sunday 27 May 2012) I have been experiencing the follwing problems:

A. I am unable to map macros to my mouse buttons. They appear within the mapping application but can get them to work. Basic left and right click and mouse scroll seem to work fine but buttons 4,5 6 & 7 dont do anything.

B. Periodically, the keys seem to reverese where all key register caps. In addition, pressing <Cntl> +<ESC> causes windows task manager to launch.

I have read about on this and have tried the following:
1. Pressed both shift keys: temporarily sorts the CAPs issue but this soon comes back. This has no effect on the inability to use my mouse keys in Para A above.
2. Reinstalled Razer mouse drivers. No effect.
3. Remapped macros on Mamba mouse. No effect.
4. re-installed SWTOR installer. No effect.

I am running Windows 7 Home Premium 64-bit.

To say this is slightly annoying is an understatement anyone experiencing the same? Has anyone found a resolution aside from using a bog standard mouse and binning the macros?

All advice well recieved

Sutii's Avatar


Sutii
05.28.2012 , 11:08 PM | #2 Click here to go to the next staff post in this thread. Next  
Hello Shep_Kennelly,

Unfortunately we are unable to provide direct support for third party devices and hardware. We can however recommend that you ensure all software for such devices is up to date and that it, as well as SWTOR, is run in administrator mode.

Thank you for your understanding.
Sutii | BioWare Customer Service - Forum Support

Ameepa's Avatar


Ameepa
05.29.2012 , 01:06 AM | #3
Sounds like your shift-key gets stuck in down position. Have you spilled something on your keyboard?
If not, there may be some other fault with the shift button. Change your keyboard.

Your mouse buttons do not work because they are now "shift+mousebutton", not just "mousebutton". And that task manager thingie is because ctrl+shift+esc opens it. The all-caps-thing is of course related to that shift button too :P

Edit: There seems to be sticking shift-key issues with that Razer keyboard model. Youtube link to review: http://www.youtube.com/watch?v=Gl3qgBoW3F4

Rayleamon's Avatar


Rayleamon
08.05.2012 , 03:39 AM | #4
i have a simler issue with the razer Lycosa keyboard but its only in the louncher that isthe issue as you can see and only been a issue today the 05/08/12
update its only happening in the password section of the louncher not the username section

Petnil's Avatar


Petnil
08.05.2012 , 07:20 AM | #5
iīm also having mouse problems. my mouse "disconnects" (cant realy happens since itīs not wireless) and then reconnects a few sec later. keyboard works fine so i can work around for the most part. Spacemissions are near impossible tho. Ofc the answer from EA will be itīs a driver issue. The strange thing is i never had this problem untill i installed swtor. In my book itīs a bug in the game.
my mouse issue stopped when 1.2 went live, but it was shot lived. Servers shut down after a day or so because some areas was missing or something, cant remember exactly. when servers came back online my problems had returned. That made me even more certain itīs a game issue.
all drivers are up to date, i even got me one of those programs that auto update all drivers to see if that would fix things. Only thing i havenīt tried is a reinstall of swtor. Maybe that will help.

Sutii's Avatar


Sutii
08.05.2012 , 07:30 AM | #6 This is the last staff post in this thread.  
Quote: Originally Posted by Rayleamon View Post
i have a simler issue with the razer Lycosa keyboard but its only in the louncher that isthe issue as you can see and only been a issue today the 05/08/12
update its only happening in the password section of the louncher not the username section
Hello Rayleamon,

As in my previous post, we are unfortunately unable to provide direct support for third party devices and hardware. I would recommend however that you attempt, if possible, using a different keyboard to see if the issue persists even then.

Thanks.


Quote: Originally Posted by Petnil View Post
iīm also having mouse problems. my mouse "disconnects" (cant realy happens since itīs not wireless) and then reconnects a few sec later. keyboard works fine so i can work around for the most part. Spacemissions are near impossible tho. Ofc the answer from EA will be itīs a driver issue. The strange thing is i never had this problem untill i installed swtor. In my book itīs a bug in the game.
my mouse issue stopped when 1.2 went live, but it was shot lived. Servers shut down after a day or so because some areas was missing or something, cant remember exactly. when servers came back online my problems had returned. That made me even more certain itīs a game issue.
all drivers are up to date, i even got me one of those programs that auto update all drivers to see if that would fix things. Only thing i havenīt tried is a reinstall of swtor. Maybe that will help.
Hello Petnil,

As with Rayleamon above, I would advise that you try using a different mouse to see if the problem is still present. Additionally to this could I recommend that you attempt using a different USB port than the one your mouse is currently plugged in to, as this could also be caused by a faulty connection.

Thank you again, and should either of you require assistance with anything else, please do not hesitate to contact us.
Sutii | BioWare Customer Service - Forum Support

Petnil's Avatar


Petnil
08.05.2012 , 07:35 AM | #7
i tried just about every usb port. Also after having a day or so with no problems when 1.2 went live suggests itīs a game issue. I havenīt tried with a mouse change.I willl see if i can find some old mouse somewhere

Valek_Hawke's Avatar


Valek_Hawke
07.07.2013 , 06:49 PM | #8
Well, granted it's almost a year later, but I am starting to have similar problems and NOT with a Razer product. It amazes me how you guys (being Bioware) so quickly try to get out of helping your player base by passing the problem off as someone else's and saying it's not your responsibility without even seeing if there is a problem. I have a Microsoft keyboard, USB that approximately 2 weeks ago I started having issues where when I would hold a movement key down, usually the "W" key, but certainly not limited to it it is as if the key would stick...not physically, but the movement would continue for anywhere from 10 to 20 seconds and nothing I do stops it. It just stops on it's own. As you can imagine it makes playing Flashpoints and OPs impossible. I thought at first that it might be the keyboard that was having issues with the key(s) so I RMA'd it and got a brand new keyboard. Same thing kept happening. I then moved it to a different USB header thinking that that might be the issue but the issue persists regardless of what USB port I have the keyboard plugged into. So how 'bout pulling your head out of...the sand and looking around and seeing what's going on. I'm sure I'm not the only one who's having issues. And yes, the drivers are the most current for this keyboard even though no drivers are necessary.