Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

I Login, click Play, screen goes black, crash to desktop

STAR WARS: The Old Republic > English > Customer Service
I Login, click Play, screen goes black, crash to desktop
First BioWare Post First BioWare Post

Plicitous's Avatar


Plicitous
05.27.2012 , 02:52 PM | #1
I Login, click Play, screen goes black for a second like it's trying to start the game and them boom I'm back at the desktop and SWTOR isn't visible in Task Manager.

Ran fine for 5 months, I unsubbed and uninstalled and eventually re-subbed and reinstalled and haven't been able to launch the game since. I've reinstalled twice, run the FixLauncher multiple times, repaired multiple times, updated video drivers, run as administrator, verified that nothing is running in the background and nothing works. I can't launch the game. It goes black and crashes to the desktop every time. Please help.

If I can't fix this issue soon I'd at least like the $14.99 I paid to re-sub back since I won't have used any of my game time.

Beruthien's Avatar


Beruthien
05.27.2012 , 02:55 PM | #2 Click here to go to the next staff post in this thread. Next  
Greetings Plicitous,

Please try hitting Alt+Enter while you get the black screen. This should place the game into windowed mode and allow you to enter the game.

If this does not resolve the issues please go to the following location:
Code:
C:\Users\%USERNAME%\AppData\Local\SWTOR\swtor\settings
Open the client_settings and copy the contents of the file and post it here.

I hope this helps!
Beruthien| BioWare Customer Service – Forum Support

Plicitous's Avatar


Plicitous
05.27.2012 , 03:15 PM | #3
Quote: Originally Posted by Beruthien View Post
Greetings Plicitous,

Please try hitting Alt+Enter while you get the black screen. This should place the game into windowed mode and allow you to enter the game.

If this does not resolve the issues please go to the following location:
Code:
C:\Users\%USERNAME%\AppData\Local\SWTOR\swtor\settings
Open the client_settings and copy the contents of the file and post it here.

I hope this helps!
Thank you for the prompt response! Tried ALT-Enter a couple of times but the black screen is so quick to come and go that I'm not sure I pressed it in time. Here's the contents of my client_settings.ini file:

[Renderer]
Buckets = 2
D3DFullScreen = true
GraphicsDeviceId = 26815
Height = 1024
MeshLODQuality = 1
NativeHeight = 1024
NativeWidth = 1280
PerformanceLevelChanged = true
TextureAnisotropy = 16
Width = 1280

My resolution is currently set to 1366x768. I'm guessing that might have something to do with the problem since the .ini file looks to have different settings.

Beruthien's Avatar


Beruthien
05.27.2012 , 03:18 PM | #4 Click here to go to the next staff post in this thread. Next  
Greetings Plicitous,

Please change the line D3DFullScreen = true to D3DFullScreen = false and try to start the game.

If you are able to start the game then you can modify the graphic options from the in-game menu.

If the issue remains please come back to us.

I hope this helps!
Beruthien| BioWare Customer Service – Forum Support

Plicitous's Avatar


Plicitous
05.27.2012 , 03:23 PM | #5
Quote: Originally Posted by Beruthien View Post


I hope this helps!
Worked! Thanks Beruthien!

Beruthien's Avatar


Beruthien
05.27.2012 , 03:26 PM | #6 Click here to go to the next staff post in this thread. Next  
Glad to have been of assistance!

Have fun in-game and don’t hesitate to come back to us if you have any further issues or questions!
Beruthien| BioWare Customer Service – Forum Support

Lastante's Avatar


Lastante
07.02.2012 , 02:03 PM | #7
I don't have a client_ folder to look at...
and I have the same problem

Lastante's Avatar


Lastante
07.02.2012 , 02:06 PM | #8
I do not have the: client_settings.ini file: and the only folder with the D3D that I have is to DDO game and their folder is called a users preference folder.


[Renderer]
Buckets = 2
D3DFullScreen = true
GraphicsDeviceId = 26815
Height = 1024
MeshLODQuality = 1
NativeHeight = 1024
NativeWidth = 1280
PerformanceLevelChanged = true
TextureAnisotropy = 16
Width = 1280

Lastante's Avatar


Lastante
07.02.2012 , 02:58 PM | #9
My folder is not called Clients_Settings it is called Clients_Defaults . How it appears below is everything that it says in folder. And the only thing I changed was Fullscreen to False. That got me into window mode, but heres the kicker...when I was in the game in window mode I thought well maybe now I can click on fullscreen...and my screen went into completel flicker mode and took over my computer. I could not even open my Task Manager and view it becuase my screen was in constant flicker mode. Had to log out. So window mode works. It is obvious that the fullscreen option is malfuntioning.

// WARNING: ** DO NOT EDIT THIS FILE ** //
// Making any changes to this document will result in the corruption of //
// your install and will require the use of the repair utility. //
//--------------------------------------------------------------------------//
[Renderer]
Width=1600
Height=900
WindowX=-1
WindowY=-1
FullScreen=false
doShadows=true
[Repository]
BaseResourceFileName=..\..\Assets\swtor_

Beruthien's Avatar


Beruthien
07.02.2012 , 03:19 PM | #10 Click here to go to the next staff post in this thread. Next  
Greetings Lastante,

The client_defaults and client_settings are 2 different files. If have Windows 7 or Windows Vista you can copy the directory I gave before to Internet Explorers address bar to open the correct folder.

If you are unable to locate the folder, it might be that your AppData folder is hidden. You may need to enable viewing of hidden files (you can disable this function later).

Please come back to us with your Client_settings file and your DxDiag.

Thank you!
Beruthien| BioWare Customer Service – Forum Support