Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Laptop not using dedicated graphics card for SWTOR

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Laptop not using dedicated graphics card for SWTOR
 

SpanishJim's Avatar


SpanishJim
12.18.2011 , 01:27 AM | #1
Hi all,

I'm having an issue with low FPS on a HP Pavilion dv6-6193ca (specs below)

I believe the low FPS is due to the fact that SWTOR is using the onboard graphics card over the dedicated Radeon card.

I tried setting swtor.exe to "High Performance" in the switchable graphics section in Catalyst Control Center. This should force the game into using the Radeon card, however the game loads up with NO graphics at all (only audio).

I currently only have one other game on the Laptop (StarCraft II) which works fine in "High Performance" mode using the Radeon card.

After update all drivers the issue persists. The graphics drivers come from HP (the standard ATI drivers do not work)

The game is playable using the onboard card with about 20-30fps with no shadows and low shader complexity.

Any help is appreciated.

-------------------------------------
Intel® Core™ i7-2630QM 2 GHz
8 GB DDR3
AMD Radeon HD 6490M (1 GB GDDR5)

AMD High-Definition Graphics Driver 2011-11-18 ,Version:8.882.2.3000

Oisselo's Avatar


Oisselo
12.29.2011 , 08:37 PM | #2
i am having same issues with same specs you have expect i have a samsung series 7 chronos with 512mb


Samsung Series 7 Chronos (bestbuy version )
Intel i7-2675QM 2.2ghz
6GB DDR3 RAM
AMD(ATI) Radeon HD 6490M 512MB DDR5

KeithI's Avatar


KeithI
12.29.2011 , 08:40 PM | #3
Right click the application .exe file. The one your swtor folder. There should be an option allowing you to select what card you would like to use. Hope it helps.

Oisselo's Avatar


Oisselo
12.29.2011 , 08:48 PM | #4
Ill give it a shot thanks!

Oisselo's Avatar


Oisselo
12.29.2011 , 08:55 PM | #5
Right clicking on the .exe in the swtor directory does not show an option of being able to select which graphics but i do have it as performance in catalyst control center. Also i would like to make a note that every time i shutdown swtor my CCC starts flipping out then eventually force closes, note that this does not happen with any other game i play. I am thinking maybe it is AMD failing to switch back to the intel base graphics one swtor closes and also CCC then fails to act correctly until a system restart, but like i said this only happens with swtor.
Samsung Series 7 Chronos
Intel i7-2675QM 2.2ghz
6GB DDR3 RAM
AMD Radeon HD 6750M 1GB DDR5/intel hd graphics

Maric_Drace's Avatar


Maric_Drace
01.17.2012 , 09:31 PM | #6
HP Dv7-6cus same problems you are describing. Updated drivers and catalyst. still get black screen when running with AMD settings on. Any luck on curing this problem?

NegativeDown's Avatar


NegativeDown
01.17.2012 , 09:54 PM | #7
Don't use the ATI drivers HP provides as those are way out of date. I've got a dv6tqe and had the same issue with black screens and the high performance switch before I grabbed the 12.1a version from the link below and it has run flawlessly since.

http://forums.guru3d.com/showthread.php?t=356768

Maric_Drace's Avatar


Maric_Drace
01.18.2012 , 01:02 PM | #8
In the new patch notes it says that it fixed some issues with black screen rendering on ATI cards. Ran a catalyst update as well. One of these fixed the issue. I actually think it was the patch because I have run the catalyst update before with the same problem. Current driver version is 8.882.2.3000

The link above is a newer version of the drivers but is beta. I may still run it just to get things up to date but at this point have no problems.

Thanks for all the help.

eggiepay's Avatar


eggiepay
01.21.2012 , 04:09 AM | #9
hey guys - I have a HP DV7 - the post following solved all my probs....



" something so simple - FPS in Fleet went from 10 to constant 30 - game is actually playable (also changed from active to passive cooling plan)

I can actually hear my Graphics card fan working (not overworking but standard noise I get for most games)

You (rather than Bioware) have saved a subscription

specs - lappy i7 8gb ram 6770"




Quote:
Originally Posted by KazerDragon
This worked. I was suffering problems. I had 1.6 fps in Civil War and 10 fps in Fleet. In my ship I would be at 90, opening my inventory over and over would bring me to 6 fps.

I am using an Alienware m17x (Laptop) with Windows 7 64bit
Intel Core i7 2670QM 2.2GHz (3.1GHz w/Turbo Boost, 6MB Cache)
8GB Dual Channel DDR3 at 1600MHz (4DIMMS)
1.5GB GDDR5 NVIDIA GeForce GTX 560M

(This is for laptop and Alienware, I honestly don't know about other machines or if this will work for you)

With Windows 7, I went to Control Panel, System and Security, Power Options. On the page where it says Select a Power Plan, click "Show additional plans" which is right underneath the 2 Plans you can select (Balance and Power Saver). You should see one more plan appear for High Performance. Select it.

Now in-game for swtor, I have turned all my graphics down to the lowest settings and turned off shadows, and I have Windowed mode with 1600x900 resolution. I have CPU-Z and my Core Speed is now always at 2790.8 MHz with a Multiplier at x28.0 as opposed to where it would typically remain at 800MHz. My Core Temp reads 65(C) - 69(C) degrees for my 4 cores.

Taking it further, there are settings to make sure you're running at 100%. If needed you can click "Change Plan Settings" to the right of the High Performance Plan. Now I'm on a laptop. You can see Dim the Display, Put Computer to Sleep, etc. Right below "Adjust Plan Brightness" are some options, select "Changed Advanced Power Settings." Go to Processor Power Management and make sure they're 100% when plugged in (this was already default but I followed some instructions) Maybe you don't need to do that after all, whatever.



I'm sorry if this didn't help you or if this has been already suggested.
I'm not too computer savy. I never got Windows 7 for a desktop. I've tried a few things like going in the BIOS, re-installing various drivers, moved the client.ini and started the game fresh, and so on. Again, I don't know that much about hardware and software but this is what I did and I haven't suffered any FPS problems since I changed this. I can't even say if this would be harmful to my machine, maybe you all would know. If this works for you then congrats, if not, sorry I'm not much of help. Good luck.

Diverburgh's Avatar


Diverburgh
01.08.2013 , 05:20 PM | #10
Quote: Originally Posted by NegativeDown View Post
Don't use the ATI drivers HP provides as those are way out of date. I've got a dv6tqe and had the same issue with black screens and the high performance switch before I grabbed the 12.1a version from the link below and it has run flawlessly since.

http://forums.guru3d.com/showthread.php?t=356768
I've done this and it solved the black screen problem. Plus my screen is much livelier, and oddly enough it runs much faster now.

Bless you mate!