Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Severe artifacting and crashes.

 

istateside's Avatar


istateside
05.06.2012 , 09:41 AM | #1
I've had SWTOR since launch, and the game always ran smoothly. Had everything on the highest settings, at 1680x1050. I ended my subscription sometime around February, and just resubbed after the free weekend. On that weekend, the game ran smoothly, but for whatever reason, the week after I resubscribed, the game has become nearly unplayable. On the character creation screen and in-game, the screen will suddenly lock up or flicker black. This will happen a few times, and every time it goes black, the loading window pops up and the whole screen starts reloading.

If this stops, the game starts artifacting severely. Things will get very pixelated, and the framerate will drop very low. Eventually, it crashes, so I typically quit the game if it gets too bad. I've gotten a BSOD from this twice before.

I've got a GeForce GTX 260, and that should be plenty to run the game. I've tried turning the settings all the way down to low and dropping the resolution down, but this only delays the effect. I opened my tower case and cleaned out all the dust with a compressed air can, which seemingly fixed the problem. I was able to play for about a day, but the problem has come back in full force. My drivers are up to date, and I've got the latest Direct X installation.

DXDiag log:
Spoiler

Nightsong's Avatar


Nightsong
05.06.2012 , 09:56 AM | #2
I also have gotten severe artifacting and have crashed to desktop once since I got the last patch. Never had this problem in the past. I got the latest drivers for my card, but the problem persists with artifacting and see-though sections of the world, only to a lesser degree. Any suggestions on how I can get this fixed?

Also, I'm not a computer savvy person, but I'm getting environmental textures in places they shouldn't be. I had to quit playing at one point because I couldn't see where I was going for all the wall textures blocking my view. I could go though them, but they looked solid, and blocked what is normally a corridor. Have no idea what that is called, tried looking it up, no luck.
PEACE IS A LIE, BUT SO IS PASSION
Proud member of the Grey Jedi

istateside's Avatar


istateside
05.08.2012 , 01:59 PM | #3
Any ideas?

Drength's Avatar


Drength
05.08.2012 , 03:50 PM | #4
What was the error on the BSOD?