Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Loading issues YES another thread about it with a twist

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Loading issues YES another thread about it with a twist
 

ScottVicious's Avatar


ScottVicious
12.17.2011 , 02:32 PM | #1
I am in game but then I am not, I can move around even friends tell me im in game but the load screen still says im at 50% (after a good hour now) I hit alt z and can move around play like im in game but the load screen is still smack dab in the middle of my screen all I can see is the ui

ScottVicious's Avatar


ScottVicious
12.17.2011 , 03:53 PM | #2
anyone get this bug before anyone?

ScottVicious's Avatar


ScottVicious
12.17.2011 , 04:23 PM | #3
anyone at all

Rastai's Avatar


Rastai
12.17.2011 , 04:30 PM | #4
same here, i can walk and jump and all that but only got one big loading screen to look at. i am out of ideas, tried everything.

ScottVicious's Avatar


ScottVicious
12.17.2011 , 04:56 PM | #5
i cant even tell if i can jump i can see myself on my mini map and even open all the tools hard to play a game when the splash screen is the only thing you see

Zaelesis's Avatar


Zaelesis
12.17.2011 , 05:03 PM | #6
Im having this bug as well on my main, its really making it difficult to want to buy the game if i cant play.

ScottVicious's Avatar


ScottVicious
12.17.2011 , 05:38 PM | #7
seems to happen for me no matter what server I am on same concept glad it is not just me

Fathermc's Avatar


Fathermc
12.17.2011 , 05:42 PM | #8
wow, today must be the day.


the game was working fine now we are all getting a bunch of problems!

Taystee's Avatar


Taystee
12.17.2011 , 06:09 PM | #9
bump, same issue.

Happened at Trooper Prologue Loading screen after hitting level 10 and going on the ship to the Republic Fleet.

ScottVicious's Avatar


ScottVicious
12.17.2011 , 07:09 PM | #10
I even tried to kill myself and it wouldnt even let me respawn.....