Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Launcher not loading game.


RLASMF's Avatar


RLASMF
12.17.2011 , 02:23 PM | #1
Hello I am new to this game first time playing and I am having trouble getting into the game. I put in all my info and the security key and then a click login. The screen flashes black for a second and then I have to reopen the launcher and the same thing keeps happening when I try to log in. I checked everything with the firewall and allowing the game to run and it is so I dont know what is wrong. I even reinstalled the game and that didnt work either. I tired to click the fix option but it wont let me because it says I need to finish patching it but nothing loads when I open up the launcher to even finish patching it like says. Help me please!

Silvia's Avatar


Silvia
12.17.2011 , 02:27 PM | #2
Same problem here for over 3 days...
POWER TO THE DAXSON

armus_idrac's Avatar


armus_idrac
12.17.2011 , 02:32 PM | #3
I had the same issue. I deleted all the files/folders pertaining to swtor EXCEPT for the Assests and Movies folders. Then, run the installer again. After I did that, I clicked on the launcher fix (this may not be necessary). Make a new launcher icon and launch from that. After I did that, it hasn't given me problems since.

kiern's Avatar


kiern
12.17.2011 , 02:46 PM | #4
The best bet would be to go into the log folder and open the latest log, and see if it tells you where it is running into problems.

Here are a couple I ran into during beta, that sound similar.

If you have not rebooted, there may be a process for the game still running. It used to get stuck every now and them. If you got into the Windows task manager and click on the "processes" tab scroll through it and see if you see a process running, either the SWTOR one, or the launcher. If so, click on it and end the process....or you could simply reboot your computer.

Another thing you might try is deleting the retailclient_swtor.version file, and then launch the game again.

THgodOneTwoSix's Avatar


THgodOneTwoSix
12.17.2011 , 03:24 PM | #5
I have been having the same exact problem. I updated my DirectX and my system and still the flashing black screen. I recorded my screen to see if anyone has the same problem, here it is -> http://www.youtube.com/watch?v=7owob7b4Yiw

My graphics card doesn't meet the minimum requirements, I'll have to admit. But it never met the minimum requirements on any game I played on my computer, including WoW. I only expected to play on the lowest graphics settings anyway, but this won't even bother to start up. If updating my graphics card or buying a new computer is the only option...then screw it, ill have to wait

RLASMF's Avatar


RLASMF
12.17.2011 , 05:23 PM | #6
@ THgodOneTwoSix - that is exactly what is happening to me.

@armus_idrac - I am trying that right now I deleted it all but what you said and now its installing the game again.

Azithrom's Avatar


Azithrom
12.17.2011 , 05:39 PM | #7
Same damn problem here. E-mailed customer service about ten hours ago, no reply and their phone system keeps telling me to call back later.

RLASMF's Avatar


RLASMF
12.17.2011 , 05:47 PM | #8
@Azithrom - If they ever answer you let me know what they say.

Azithrom's Avatar


Azithrom
12.17.2011 , 06:08 PM | #9
Here is the e-mail I just received. I don't have a AMD graphics card though so it was a tad pointless.

"Greetings,

I am Protocol Droid M0-T0, human-cyborg relations.

We are aware that there is an issue with some of the recent versions of ATI (AMD) graphics drivers which are causing problems with entering Star Wars: The Old Republic. In order to help fix this we would ask that you ensure you are using the latest driver version by downloading and installing it directly from the AMD website at http://support.amd.com/us/gpudownload/Pages/index.aspx.

For further useful information about updating graphics card drivers please visit our Help Center article at: http://www.swtor.com/support/helpcenter/1942.

Please do not hesitate to contact us again if you have any other issues or queries that you would like assistance with.

Galactic Support is our specialty....

Sincerely,

Protocol Droid M0-T0
Star Wars: The Old Republic Customer Service"

RLASMF's Avatar


RLASMF
12.17.2011 , 06:28 PM | #10
@ armus_idrac - Just tried it, and it did not work.

@ Azithrom - Yup that is pointless.

Still looking for the answer on how to fix this....