Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Helm Not Displaying

First BioWare Post First BioWare Post

Chaori's Avatar


Chaori
04.15.2012 , 01:19 AM | #1
Ever since updating to patch 1.2 my helm does not display on my Twi'lek Assassin. I have done a fresh reinstall (had to because of patch error), I have tried unticking and ticking the Hide Head Slot option, I have unequipped my headpiece and re-equipped it, I've tried another type of headpiece and none of them display on my character no matter what I do. Is there a way to fix this?

Others have confirmed that they cannot see it on me either, so it can't be an issue with my client.

Chaori's Avatar


Chaori
04.17.2012 , 11:39 PM | #2
Bump! I realise there are multiple threads for this one issue but I have yet to see a Customer Service rep confirm as to whether or not this is a known bug and if/when it will be fixed.

Have been keeping an eye on the list of known bugs over the past week and noticed that the helm display bug has yet to be added. Can a Customer Service rep please confirm if this issue is being looked into and maybe get an ETA on when we can have our helms back.

Thanks.

Naaruna's Avatar


Naaruna
04.24.2012 , 01:04 AM | #3
i am having the same problem . . . . . . .

I also cannot preview helms with one exception.

if I try to preview a helm that someone else has equipped then I can see it on my preview . . . .but otherwise, no helm is visible on preview or when equipped by me. I also tried ticking show helm off and on with no luck.

Chaori's Avatar


Chaori
04.27.2012 , 08:47 AM | #4
I really wish a Customer Service 'Droid' would comment about this. It has been weeks now and the helm not displaying bug has STILL not been added to the known issues - despite my multiple tickets being "forwarded to the dev team".
I'm getting sick of apologies for the inconvenience, all I want to know is what is being done about it. I've waited patiently while other issues are addressed but even some acknowledgement on this issue would be something - from the info I've had you may as well just be ignoring the issue altogether. This issue NEEDS to be addressed, what is the point in playing the game to get gear and not even be able to see it?

Chaori's Avatar


Chaori
05.03.2012 , 06:28 AM | #5
Bump!

robertszak's Avatar


robertszak
05.03.2012 , 08:10 AM | #6
According to a customer service droid in this post:
http://www.swtor.com/community/showt...46#post4240146

This is not a bug, but working as intended. /facepalm

Chaori's Avatar


Chaori
05.03.2012 , 05:29 PM | #7
***! If I knew by going Twi'lek I wouldn't be able to use headgear I would have picked another race.. That is fking ridiculous.

What are the chances people that don't like it can get a free race change? :/

Ogada's Avatar


Ogada
05.03.2012 , 11:30 PM | #8 Click here to go to the next staff post in this thread. Next  
Hi folks,

We have had several reports of head gear not working randomly and so we are investigating. Thank you for the report.

Sorry for any inconvenience this has caused you.
Ogada | BioWare Customer Service Forum Support

Chaori's Avatar


Chaori
05.04.2012 , 12:22 AM | #9
Thanks for the update, but is this ACTUALLY a bug? Seems a bit silly that people don't even get the choice to display their helm or not.

Axolipher's Avatar


Axolipher
05.04.2012 , 08:18 AM | #10 Click here to go to the next staff post in this thread. Next  
Greetings Chaori,

Once again, Thank you for your report. I can understand your frustration in not knowing what the current status of this issue is.

Unfortunately as we are still investigating this issue we are not able to officially classify the status/whether this issue is a bug or not.

I can however assure you that it is actively being investigated and looked into at the moment.

Thank You.

Axolipher | BioWare Customer Service - Forum Support