Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Error Code: c7 Incompatible system.

STAR WARS: The Old Republic > English > Customer Service
Error Code: c7 Incompatible system.
First BioWare Post First BioWare Post

RaineGaming's Avatar


RaineGaming
04.13.2012 , 10:57 PM | #1
So i just bought this game and installed the whole thing and i got error code after logging in.

it says exactly : SWTOR
This program encountered an internal error and will exit.
Error code: c7
Incompatible system. Please verify your system is compatible with this game.




I updated my graphics card and still nothing.

heres my dxdiag. up to the sound devices.


Code:
System Information
------------------
Time of this report: 4/13/2012, 21:53:27
       Machine name: OEM
   Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 3 (2600.xpsp_sp3_gdr.111025-1629)
           Language: English (Regional Setting: English)
System Manufacturer: MICRO-STAR INC.
       System Model: MS-6728
               BIOS: Version 1.00
          Processor: Intel(R) Pentium(R) 4 CPU 2.80GHz (2 CPUs)
             Memory: 2048MB RAM
          Page File: 727MB used, 3216MB available
        Windows Dir: C:\WINDOWS
    DirectX Version: DirectX 9.0c (4.09.0000.0904)
DX Setup Parameters: Not found
     DxDiag Version: 5.03.2600.5512 32bit Unicode

------------
DxDiag Notes
------------
  DirectX Files Tab: No problems found.
      Display Tab 1: No problems found.
        Sound Tab 1: No problems found.
          Music Tab: No problems found.
          Input Tab: No problems found.
        Network Tab: No problems found.

--------------------
DirectX Debug Levels
--------------------
Direct3D:    0/4 (n/a)
DirectDraw:  0/4 (retail)
DirectInput: 0/5 (n/a)
DirectMusic: 0/5 (n/a)
DirectPlay:  0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow:  0/6 (retail)

---------------
Display Devices
---------------
        Card name: NVIDIA GeForce 6800
     Manufacturer: NVIDIA
        Chip type: GeForce 6800
         DAC type: Integrated RAMDAC
       Device Key: Enum\PCI\VEN_10DE&DEV_0041&SUBSYS_A3433842&REV_A1
   Display Memory: 128.0 MB
     Current Mode: 1280 x 960 (32 bit) (60Hz)
          Monitor: Plug and Play Monitor
  Monitor Max Res: 1600,1200
      Driver Name: nv4_disp.dll
   Driver Version: 6.14.0012.9610 (English)
      DDI Version: 9 (or higher)
Driver Attributes: Final Retail
 Driver Date/Size: 2/29/2012 16:58:00, 4309760 bytes
      WHQL Logo'd: n/a
  WHQL Date Stamp: n/a
              VDD: n/a
         Mini VDD: nv4_mini.sys
    Mini VDD Date: 2/29/2012 16:58:00, 13417632 bytes
Device Identifier: {D7B71E3E-4301-11CF-787E-4F8300C2CB35}
        Vendor ID: 0x10DE
        Device ID: 0x0041
        SubSys ID: 0xA3433842
      Revision ID: 0x00A1
      Revision ID: 0x00A1
      Video Accel: ModeMPEG2_C ModeMPEG2_D 
 Deinterlace Caps: {6CB69578-7617-4637-91E5-1C02DB810285}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive 
                   {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch 
                   {6CB69578-7617-4637-91E5-1C02DB810285}: Format(In/Out)=(UYVY,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive 
                   {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(UYVY,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch 
                   {6CB69578-7617-4637-91E5-1C02DB810285}: Format(In/Out)=(YV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive 
                   {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch 
                   {6CB69578-7617-4637-91E5-1C02DB810285}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive 
                   {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch 
         Registry: OK
     DDraw Status: Enabled
       D3D Status: Enabled
       AGP Status: Enabled
DDraw Test Result: Not run
 D3D7 Test Result: Not run
 D3D8 Test Result: Not run
 D3D9 Test Result: Not run
-------------
Sound Devices
-------------
            Description: Realtek AC97 Audio
 Default Sound Playback: Yes
 Default Voice Playback: Yes
            Hardware ID: PCI\VEN_8086&DEV_24D5&SUBSYS_00801462&REV_02
        Manufacturer ID: 65535
             Product ID: 65535
                   Type: WDM
            Driver Name: ALCXWDM.SYS
         Driver Version: 5.10.0000.5420 (English)
      Driver Attributes: Final Retail
            WHQL Logo'd: n/a
          Date and Size: 12/19/2003 05:07:50, 541548 bytes
            Other Files: 
        Driver Provider: Realtek Semiconductor Corp.
         HW Accel Level: Full
              Cap Flags: 0x0
    Min/Max Sample Rate: 0, 0
Static/Strm HW Mix Bufs: 0, 0
 Static/Strm HW 3D Bufs: 0, 0
              HW Memory: 0
       Voice Management: Yes
 EAX(tm) 2.0 Listen/Src: Yes, Yes
   I3DL2(tm) Listen/Src: Yes, Yes
Sensaura(tm) ZoomFX(tm): No
               Registry: OK
      Sound Test Result: Not run

---------------------
Sound Capture Devices
---------------------
            Description: Realtek AC97 Audio
  Default Sound Capture: Yes
  Default Voice Capture: Yes
            Driver Name: ALCXWDM.SYS
         Driver Version: 5.10.0000.5420 (English)
      Driver Attributes: Final Retail
          Date and Size: 12/19/2003 05:07:50, 541548 bytes
              Cap Flags: 0x0
           Format Flags: 0x0

-----------
DirectMusic
-----------
        DLS Path: C:\WINDOWS\SYSTEM32\drivers\GM.DLS
     DLS Version: 1.00.0016.0002
    Acceleration: n/a
           Ports: Microsoft Synthesizer, Software (Not Kernel Mode), Output, DLS, Internal, Default Port
                  Realtek AC97 Audio, Software (Kernel Mode), Output, DLS, Internal
                  Microsoft MIDI Mapper [Emulated], Hardware (Not Kernel Mode), Output, No DLS, Internal
                  Microsoft GS Wavetable SW Synth [Emulated], Hardware (Not Kernel Mode), Output, No DLS, Internal
        Registry: OK
     Test Result: Not run

-------------------
DirectInput Devices
-------------------
      Device Name: Mouse
         Attached: 1
    Controller ID: n/a
Vendor/Product ID: n/a
        FF Driver: n/a

      Device Name: Keyboard
         Attached: 1
    Controller ID: n/a
Vendor/Product ID: n/a
        FF Driver: n/a

Poll w/ Interrupt: No
         Registry: OK

-----------
USB Devices
-----------
+ USB Root Hub
| Vendor/Product ID: 0x8086, 0x24D7
| Matching Device ID: usb\root_hub
| Service: usbhub
| Driver: usbhub.sys, 4/14/2008 05:00:00, 59520 bytes
| Driver: usbd.sys, 4/14/2008 05:00:00, 4736 bytes

RaineGaming's Avatar


RaineGaming
04.13.2012 , 11:45 PM | #2
nothing? hello customer service?

Axolipher's Avatar


Axolipher
04.14.2012 , 02:35 AM | #3 Click here to go to the next staff post in this thread. Next  
Greetings RaineGaming,

After reviewing your log I noticed that your graphics card has a dedicated on-board memory of 128mb. Unfortunately the minimum specifications listed here state that a Minimum of 256MB of on-board RAM is required to play SW:TOR.

I would recommend upgrading your graphics card if you wish to play.

Thank You for your query.

Axolipher | BioWare Customer Service - Forum Support

HiddenMouse's Avatar


HiddenMouse
04.14.2012 , 04:29 AM | #4
Been playing the gmae for months and no issues, then today I am getting this!!!

This Program encounted an internal error and will Exit C7

Spoiler

Subbito's Avatar


Subbito
04.15.2012 , 12:45 AM | #5
Hello! i`ve got a problem after installing the game.
it says exactly : SWTOR
This program encountered an internal error and will exit.
Error code: c7
Incompatible system. Please verify your system is compatible with this game.

Spoiler


Please help

Darthmadius's Avatar


Darthmadius
04.15.2012 , 08:55 AM | #6
help I had to switch out my old ATI HD Radeon 4600 for an AMD HD Radeon 6670 and now Im getting the attempt to load and then crash to desktop problem...

when I tried to do it in safe mode, it said error C7

also I have this from Can you run it

Quote:
CPU
Minimum: AMD Athlon 64 X2 Dual-Core 4000+ or better, Intel Core 2 Duo Processor 2.0 GHz or better
You Have: AMD Athlon(tm) X2 250 Processor


CPU Speed
Minimum: Info
You Have: 3.0 GHz

Bios Name
Minimum: Info
You Have:
Name: Award Modular BIOS v6.00PG
Version: Award Software International, Inc. F2

RAM
Minimum: Windows XP: 1.5 GB, Windows Vista and Windows 7: 2GB, PCs using a built-in graphic chipset: 2 GB
You Have: 3.5 GB


OS
Minimum: Windows XP (Service Pack 3), Vista, 7
You Have: Microsoft Windows 7 Service Pack 1 (build 7601), 32-bit


Video Card

Minimum: 256 MB of on-board RAM and Shader model 3.0 or better support (ATI Radeon X1800 or better, NVIDIA GeForce 7800 or better, Intel 4100 Integrated Graphics or better).



You Have: AMD Radeon HD 6670

Features: Minimum attributes of your Video Card
Required

You Have

Pixel Shader version

3.0 Required

5.0 Have

Vertex Shader version

3.0 Requried

5.0 Have

Dedicated Video RAM

256 MB Required

1.0 GB Have
it says I can run this but again I get the error C7
One Day The Sith will rule The Galaxy

Sparxysparx's Avatar


Sparxysparx
04.15.2012 , 09:30 AM | #7
Quote: Originally Posted by Darthmadius View Post
help I had to switch out my old ATI HD Radeon 4600 for an AMD HD Radeon 6670 and now Im getting the attempt to load and then crash to desktop problem...

when I tried to do it in safe mode, it said error C7

also I have this from Can you run it



it says I can run this but again I get the error C7
Hi there,

Could you please browse to %localappdata%\SWTOR\swtor\settings and delete client_settings.ini and Graphics_Mirror.ini, this should reset your graphics settings.
Most crashes on startup seem to be caused by corrupted graphical settings.

Note: Getting error C7 in safe mode is normal, this game does not support being run in safe mode.

Best of luck!
I am in no way affiliated with BioWare. I am simply a Star Wars: The Old Republic player.

Kerstonbloom's Avatar


Kerstonbloom
04.16.2012 , 05:27 AM | #8
Hi,
I have also been recently started suffering the error code c7 problem and have followed all directions posted here.

I finished playing last night ( full specs no problems approx 65fps) and when i started playing today i got this error message. i have now after following all the advice here even re-installed drivers for my graphics card and tried restoring my system still with no progress.

Please can somebody help me.

Axolipher's Avatar


Axolipher
04.16.2012 , 08:05 AM | #9 Click here to go to the next staff post in this thread. Next  
Greetings all,

From the DxDiag's posted after my last post they do look capable of running our client. I would thus believe the problems you are experiencing are due to data corruption of some form. If you are still experiencing these issues I'd like you to attempt the following:
  • Goto your Assets folder inside your SWTOR base directory. If there is a folder inside the Assets directory called "SWTOR" then please rename it to "SWTOR_BACKUP". Then attempt to run the launcher again.
  • If this doesn't work, please attempt to run a repair from the launcher, and then launch the game again. This can be done by selecting the repair option in the launcher options menu. This is found by clicking the cog in the bottom left corner of your launcher after you have logged in and applied any outstanding patches.
  • If both of these steps do not work please try creating a new admin user profile within your windows user account system and see if the client works within this new user environment.

Please respond here with the results afterwards so we know if further investigation is required.

Thank You.

Axolipher | BioWare Customer Service - Forum Support

Bladehamster's Avatar


Bladehamster
04.23.2012 , 04:23 AM | #10
Hi,

I have reinstalled my NVIDIA drivers, installed the latest DirectX, i have also renamed retailclient folder and repaired everything.
But i am still getting the Error C7.

In addition, i was able to play since Early Access, until pre 1.2. Just got back from travelling and wanted to try 1.2 and could not play. I dont think its my system, i5 with 8gb ram and gtx560 TI.

Spoiler
†¶▓╬╬╬╬║▓]▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀ị† "Patience, Use the Force, Think" Proud Owner of the CE