Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Unable to change resolution in game.

STAR WARS: The Old Republic > English > Customer Service
Unable to change resolution in game.

Shantiza's Avatar


Shantiza
12.17.2011 , 04:31 AM | #1
Hi, couldn't find a thread with this particular problem.

If I change the resolution, the screen goes black for a while and then hits a loading screen and reverts to the old resolution. I assume the black screen is covering the "would you like to keep this resolution" pop up that usually comes with such things, and since I can't see it, it reverts automatically.

No idea why. Only workaround I've found is to change the resolution, then crash the game so it doesn't have time to revert. it's an annoying work around. Also experiencing FPS issues (which is why I'm messing with the resolution in the first place). I have turned shadows off.

Any help would be appreciated!

DarthVarrak's Avatar


DarthVarrak
12.17.2011 , 04:36 AM | #2
I have this same exact problem, would love some info.
Vendri Aybara, Level 50 Bodyguard Merc
<Because Good Is Dumb>
Iron Citadel

GigasFist's Avatar


GigasFist
12.17.2011 , 04:38 AM | #3
You can change it manually through the settings file.

Go to C: -> Users -> (Your User Folder) -> AppData -> Local -> SWTOR -> swtor -> client_settings (open in notepad)

Under Width and Height adjust the Resolution to the appropriate setting for your computer.

If you can't see the AppData folder Open the Control Panel select Folder Options, click the View Tab and under "Hidden files and folders" click the Show hidden files, folders, and drives.

(Instructions are for Win7 but should be very similar for XP/Vista)

Alvi's Avatar


Alvi
12.17.2011 , 05:00 AM | #4
I was having the same problem. All I can say is that i was finally able to change it but it didn't help with the lag.

I just kept messing with it and after the 37th time it finally worked...

raygungirl's Avatar


raygungirl
12.20.2011 , 10:02 AM | #5
Quote: Originally Posted by GigasFist View Post
You can change it manually through the settings file.

Go to C: -> Users -> (Your User Folder) -> AppData -> Local -> SWTOR -> swtor -> client_settings (open in notepad)

Under Width and Height adjust the Resolution to the appropriate setting for your computer.

If you can't see the AppData folder Open the Control Panel select Folder Options, click the View Tab and under "Hidden files and folders" click the Show hidden files, folders, and drives.

(Instructions are for Win7 but should be very similar for XP/Vista)
Thanks for this! I messed up my resolution without even touching it, somehow (I guess cuz I switched from full-screen to windowed and back a few times), and I couldn't change it back in game. Editing the file worked great.

Only problem now is the queue I have to sit in to get back in game when all I was really doing was relogging. Argh.
My astromech was built in Cupertino.

Kendallbwoii's Avatar


Kendallbwoii
12.20.2011 , 10:05 AM | #6
Subject: Screen error

When i click "play" on start up the screen goes black with an error saying "cannot display video mode - optimum resolution 1280 x 1024, help i really wanna play.

Spenkie's Avatar


Spenkie
12.20.2011 , 10:05 AM | #7
You will see just before your screen gets blank a small window that is asking you whether you like to have the new setting or cancel it (similar to windows) try to click on the left button which is the "agree" one even when the screen is black. (takes some time and practice to hit it) and you will approve the new resolution.

At least that is how it worked for me

Drumheadjr's Avatar


Drumheadjr
12.20.2011 , 10:10 AM | #8
As far as I could tell the reason this happens, at least for me, is that the revert timer is too short and reverts the screen settings before I was able to load the new ones. I was able to get around this by changing the settings while logged out of the game, as it is much faster when it does not need to load the game environment at the same time. Hopefully they will be able to fix the timer to start when the changes are successfully applied rather than when you hit the apply button.

Shobess's Avatar


Shobess
12.21.2011 , 12:44 PM | #9
I had this issue, when you're in game, go to the graphics options, change your refresh rate from 75zh to 60zh, after I did that I was able to put my resolution to the proper setting. Hope this helps if not im sorry

medamaniac's Avatar


medamaniac
12.25.2011 , 01:34 PM | #10
Quote: Originally Posted by GigasFist View Post
You can change it manually through the settings file.

Go to C: -> Users -> (Your User Folder) -> AppData -> Local -> SWTOR -> swtor -> client_settings (open in notepad)

Under Width and Height adjust the Resolution to the appropriate setting for your computer.

If you can't see the AppData folder Open the Control Panel select Folder Options, click the View Tab and under "Hidden files and folders" click the Show hidden files, folders, and drives.

(Instructions are for Win7 but should be very similar for XP/Vista)
I had this issue, since my HUD would be distorted and stretched out wider than it "seemed it should"

I followed these steps and it fixed the HUD to a perfect fit. Thanks for the help and I hope other spot this, as to bump it up and help themselves.
+5 Internets.