Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Bad Game Quality


DeRoiste's Avatar


DeRoiste
12.17.2011 , 04:04 AM | #1
Bad Game Quality??

I am just looking to see if anybody else is having the same problem as me with game quality.
I got my invite to the game on the 15th and since then i have been unable to play the game because of realy bad lag.It only happen's when i go indoor's or into a char instance.Now these are all problem's i never encountered in the beta.The game ran very smooth for me.I have been intouch with my IP and all is good from that end.I have also played other mmoss and also no problem there.

I got intouch with customer care and told them of my problem and they came back with the usual.Reset ur UI and restart the game.Now these are the basic moves for the exp gamer.So i replied back and told them that i had done all of the above before getting intouch with them.So they reply with the same message again.But this time added that the game was in a testing period and they were thankfull for my information.Now we have all seen the alert when we sign in that tell's us the game has been launched and it's and big day and so on.So i sent them another message asking why they would send me the same message and tell me that the game is in a testing period.When all i want is to be able to play the game and for them to give me the information i need to sort out the problem i am having,or when they will have the problem sorted.Now the sad thing about this is that they have ignored my last message and wont get intouch to help me.Now im a big boy and can take a slap in the face,because i reckon that from there statement in the second message about this being a beta testing period and also the fact that they are ignoring me.They are trying to buy time untill the game launch on the 20th.
By the way the lagging start's from the second i log in from client and as i have already stated i have no problems with other mmoss.I am also in the euro zone and living in Ireland.

If anybody else is having these problems can you let me know.It would be nice to know im not the only one Bio is giving the rubber ear!!
Or better still somebody from Bio or EA or even George himself might see this and realise that ignoring your customer's problems if far from good businness..


Yours in hope...Saive

Sachie's Avatar


Sachie
12.17.2011 , 04:16 AM | #2
Well as I was leveling up my Imperial Agent, I entered a house and my FPS just dropped from +60 to 20. Everything felt really sluggish while I was in that house. Was fine though when I got out of there and I think that's the only place I've encountered this so far.
SWORD IN BOX.

Atredes's Avatar


Atredes
12.17.2011 , 04:20 AM | #3
Specs? graphics card driver version?
Ask not what the Republic can do for you, ask what you can do for the Republic.
Greek SWTOR community @ http://www.swtor.gr

Crazzyhorse's Avatar


Crazzyhorse
12.17.2011 , 04:20 AM | #4
What are your pc specs?
blub

Ataruu's Avatar


Ataruu
12.17.2011 , 04:21 AM | #5
Post your system specs.

DeRoiste's Avatar


DeRoiste
12.17.2011 , 04:32 AM | #6
Guy's specs aint the problem..I have been running 80 man bgss in wow without a problem for 5 years..The only thing that might be against me is my graphic card is a ATI Radeon.They said in the beta that these would have a slight problem.But problem is supposed to be fixed.Plus when i played the beta the game play was so smooth i had no complaints.

hindsc's Avatar


hindsc
12.17.2011 , 04:35 AM | #7
Quote: Originally Posted by DeRoiste View Post
Guy's specs aint the problem..I have been running 80 man bgss in wow without a problem for 5 years..The only thing that might be against me is my graphic card is a ATI Radeon.They said in the beta that these would have a slight problem.But problem is supposed to be fixed.Plus when i played the beta the game play was so smooth i had no complaints.
I run a Radeon 6770, and it runs as smooth as can be. Never had any lag, aside from some server lag at the end of conversations with NPCs. Performance-wise though, I don't think I've ever dropped below 40 FPS this entire time.

Arugess's Avatar


Arugess
12.17.2011 , 04:54 AM | #8
Quote: Originally Posted by DeRoiste View Post
Guy's specs aint the problem..I have been running 80 man bgss in wow without a problem for 5 years..The only thing that might be against me is my graphic card is a ATI Radeon.They said in the beta that these would have a slight problem.But problem is supposed to be fixed.Plus when i played the beta the game play was so smooth i had no complaints.
If you can't even post your specs, then it might in fact be your computer's problem.

WoW is not a game to refer to when talking about how good your PC is.

kidatwood's Avatar


kidatwood
12.17.2011 , 05:00 AM | #9
Quote: Originally Posted by coffeoholic View Post
Really? Seriously? Is there a need for you to be a complete arse?
If you are going to be an arse you should play some game will with arse holes like WoW with will run with your pos attitude.


Try turning off your shadows if you already haven't.

yes i agree turn off your shader/shadows i did and my game runs alot smoother. i am running low end machine till tax time when i will buy something newer.

Ataruu's Avatar


Ataruu
12.17.2011 , 05:03 AM | #10
Quote: Originally Posted by DeRoiste View Post
Guy's specs aint the problem..I have been running 80 man bgss in wow without a problem for 5 years..The only thing that might be against me is my graphic card is a ATI Radeon.They said in the beta that these would have a slight problem.But problem is supposed to be fixed.Plus when i played the beta the game play was so smooth i had no complaints.

Sorry dude I lol'd so bad.