Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Lord Tarnis.. what the hell? Alone?

Grimlakin's Avatar

12.16.2011 , 10:06 PM | #1
That's about it. is it a bug that the Race to the Runis I have to do alone?

Ladydawny's Avatar

12.17.2011 , 06:28 AM | #2
I was wondering the same as I have tried 3 times to kill him alone and died with him having about 1/6th health left. I believe he is designed to be fought by player and companion? So is it some kind of bug that I cannot summon any companions?
thanks in advance

hkslayer's Avatar

12.17.2011 , 06:53 AM | #3
Having the same problem, found this video from the beta showing the companion clearly there,

*EDIT* Just figured it out, you press N and it shows your two companions and there is a little arrow you can press to summon either T7 or Kira; love it when games don't tell me things

Kheldras's Avatar

12.17.2011 , 07:14 AM | #4
Had Kira with me.. and needed to be at least Level 16... he wiped the floor in Beta, with me being 15 only, so i ran back, soloed Enemies of the Republic 2+, dinged 16 and had a hard fight.

btw, if you ALLOW it in your Preferrences, others can come with you in your Story Areas too.
...and thats the way the flatcake crumbles.

Kogaion's Avatar

12.17.2011 , 07:38 AM | #5
i belive that everything you do in your solo quests are ment to be done with a with a companion (i used Kira) is easy to beat him at lv. 16 ( and i had this fight 3 times allready betas + last night) ...the real hard fight is...


with the sith on Ord Mantell that keeps Kira prisoner
...and never forget "Any sufficiently advanced technology is indistinguishable from magic" (Clarke's third Law)...

Ladydawny's Avatar

12.17.2011 , 07:47 AM | #6
For people like me who had only had one companion up to this point, I had no idea why she had vanished, but having done so, the following info solved it for me from someone more knowledgeable in chat

At the top of the screen is a jewel shaped icon on the same bar as point tree icon and others..... etc. The jewel is the 'crew window'. Open it and your companion is in there and there is a small clicker to the right of companion to summon her. I suppose this is how u select a companion later. I really didn't have a clue it existed and thanks to the person in chat who gave me that help. I still think that the fact she vanished just as a cut scene was playing is a little buggy though you might want to look at that plz devs

I have just done the quest with companion easily and am only posting this in case someone else runs into same predicament

hanrisolo's Avatar

12.18.2011 , 05:19 PM | #7
thanks, that someone is me hehe

the companion made it easy

Boinky's Avatar

12.21.2011 , 11:11 AM | #8
Good to know it is a little tough. I tried twice last night with no success, but I'm only 14 so I'm doing side quests awhile to level up a bit.

I want my starship
"Reality is that which, when you stop believing in it, doesn't go away."
- Philip K Dick

RathSartaro's Avatar

12.21.2011 , 11:31 AM | #9
When it happened to me the crew skill gem was greyed out.

Pressing N to get crew skill window always works

dipstik's Avatar

12.21.2011 , 03:04 PM | #10
this the one one the final stage of a bonus quest near the heroic area? comes down in a ship after u use a terminal?

as a healer spec, it was a tough fight. prolly one of the hardest i remember soloing (w/comp) in beta.