Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

"Product registration code has already been used." Um, no, it hasn't.

STAR WARS: The Old Republic > English > Customer Service
"Product registration code has already been used." Um, no, it hasn't.
First BioWare Post First BioWare Post

Beslley's Avatar


Beslley
12.13.2011 , 10:36 AM | #1
So I ordered via Origin. I go to put in my product code, but it errors out and says "try again later". So I try again, and now it's telling me my product registration code has been used, only it still doesn't say I have the game registered in my product information.

What the duck?! Between this and the staggered pre-release I'm at my wits' end and just about ready to cancel my preorder. Help please

Ldwater's Avatar


Ldwater
12.13.2011 , 10:38 AM | #2
I assume you're entering the pre-order code into the registration box?

Apparently you don't need to do those steps and they are only required when the full version is released and you'll get the full version code emailed to you.

So for now try logging into the same and see if the 'play' button is enabled

Beslley's Avatar


Beslley
12.13.2011 , 10:49 AM | #3
It's not the preorder code. On my account page there is a big fracking button that says "Redeem Product Registration Code" that wasn't there before.

So I went into Origin, hit "show game details", and copypasted the product code from there (which was different from my preorder code iirc).

I put my preorder code in months ago.

This was a different code, for what I assume was the physical box/game (which I ordered digitally), and now it's saying the code is taken after the first time I put it in where it errored out.

So I don't know *** is going on.

Beslley's Avatar


Beslley
12.13.2011 , 11:02 AM | #4
Sheesh, these forums move fast.

I'm pretty close to just calling customer support. I am so fed up with how poor the customer service and communication has been for this launch.

Virheilm's Avatar


Virheilm
12.13.2011 , 11:06 AM | #5
Just above those big buttons is a paragraph that states:

Quote:
If you are a pre-order customer, the following steps are NOT required for Early Game Access. However, in order to play Star Wars™: The Old Republic™ at the official launch of the game on December 20, 2011, 12:01AM EST (Pacific: December 19th, 9:01PM; European: December 20th, 05:01AM GMT, 06:01 CET), you must first answer a series of security questions and provide your contact information. Then you must redeem a Product Registration Code that came with the game, and either subscribe to the game or redeem a Game Time Code. Follow the steps outlined below!
Quote:
If you are a pre-order customer, the following steps are NOT required for Early Game Access.
TL;DR - if you entered your pre-order code, you don't need to do that step. That code is when you get your game on the 20th, to unlock your goodies.

Beslley's Avatar


Beslley
12.13.2011 , 11:09 AM | #6
Quote: Originally Posted by Virheilm View Post
Just above those big buttons is a paragraph that states:





TL;DR - if you entered your pre-order code, you don't need to do that step. That code is when you get your game on the 20th, to unlock your goodies.
I KNOW.

The point is, right now they consider my actual code to be already taken, so when the 20th rolls around I won't be able to use this motherloving code. THAT is my issue.

Sala's Avatar


Sala
12.13.2011 , 11:14 AM | #7
Quote: Originally Posted by Beslley View Post
It's not the preorder code. On my account page there is a big fracking button that says "Redeem Product Registration Code" that wasn't there before.

So I went into Origin, hit "show game details", and copypasted the product code from there (which was different from my preorder code iirc).

I put my preorder code in months ago.

This was a different code, for what I assume was the physical box/game (which I ordered digitally), and now it's saying the code is taken after the first time I put it in where it errored out.

So I don't know *** is going on.
EXACT same issue with me. I'm not sure if that's standard or if that's a mess-up. This whole check off area is new. everything is checked off but that item and my history already shows it was completed.. so I'm unsure on why it's greyed out now.
“It is better to be alone than in bad company.” /// George Washington.

dvjdarkeye's Avatar


dvjdarkeye
12.13.2011 , 11:18 AM | #8
Had the same issue, but after 15 minutes when I checked my account page - everything was ok.

It's probably some issue with processing the "redeem code" requests.

Beslley's Avatar


Beslley
12.13.2011 , 11:21 AM | #9
Quote: Originally Posted by dvjdarkeye View Post
Had the same issue, but after 15 minutes when I checked my account page - everything was ok.

It's probably some issue with processing the "redeem code" requests.
I think it's been well over 15 minutes for me at this point, but I guess I'll keep refreshing and hope it shows up

I already submitted an online customer service request. I don't know if it will help, but hopefully they are aware of the issue already.

Palamon's Avatar


Palamon
12.13.2011 , 11:21 AM | #10
I'm in this boat as well. Bought the digital deluxe from Origin and already redeemed my code before this new 'feature' came up. Now it says my code has already been used. Of course it has, BY ME! I took out a ticket with support asking for help. I suggest you at least do the same. I've been reading other threads that say the phone support is busy. I imagine that support is overwhelmed with the early access starting today. From what I've read, we should be okay for early game access, but we'll need to get this code thing resolved by the official launch. I wonder if the forum admin can shed any light on this.