Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Website defaulting to french version

STAR WARS: The Old Republic > English > Customer Service
Website defaulting to french version
First BioWare Post First BioWare Post

Keypek's Avatar


Keypek
04.02.2012 , 12:01 PM | #1
I use the same bookmark I always have for this site and now it's going to the French version of the website. And when I pick English in the forums it'll turn some things to English but details of the posts are still in French. And when I back track everything turns back to French as default. This a bug or something on my account get screwy?

Beesodd's Avatar


Beesodd
04.02.2012 , 01:00 PM | #2 This is the last staff post in this thread.  
Greetings Keypek,

It does sound like something's gone a bit sideways. Please try clearing your browser's cookies and cache, to see if this resolves the issue.

Beesodd | BioWare Customer Service - Forum Support

Pinguaq's Avatar


Pinguaq
04.02.2012 , 01:42 PM | #3
Did you check your language setting is preferences? https://account.swtor.com/user/info
Facing forward

Keypek's Avatar


Keypek
04.02.2012 , 01:50 PM | #4
Quote: Originally Posted by Pinguaq View Post
Did you check your language setting is preferences? https://account.swtor.com/user/info
They were set to English but just going to my account page and viewing it then going back to the homepage seems to have reset it to English. Thanks. Not sure what happened there.