Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Error "Was not able to launch the game"

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Error "Was not able to launch the game"

Ambraura's Avatar

12.16.2011 , 07:29 PM | #1
I had to do a recover to the last good starting point on my PC. Since doing this the game will not launch. I've done:

1) Tried to re-install the client by downloading the launcher and choosing the re-install option.
2) checking all anti-virus settings, firewall settings, and administrative settings. All are correct.

But I still the the error "Was not able to launch the game". Is there any way to fix this without a complete uninstall and re-downloading the entire game? The previous re-install didn't download anything new.

Blowebassman's Avatar

12.18.2011 , 09:01 PM | #2
Hey I just had the same issue and I fixed it. Open the launcher, click on the gears button (config?) and then click repair.

that worked for me

good luck!