Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

SWTOR won't launch after I press play.

STAR WARS: The Old Republic > English > Customer Service
SWTOR won't launch after I press play.
First BioWare Post First BioWare Post

Mexicanoperson's Avatar


Mexicanoperson
03.26.2012 , 05:34 PM | #1
I can log on, but when I press play, the screen just goes black and goes back to my desktop. I've repaired it twice, restarted my pc, but still does the same thing. PLEASE HELP!!

RicoFrost's Avatar


RicoFrost
03.26.2012 , 06:26 PM | #2
Right click the shortcut and select compatibility tab.

Tick run this program in compatibility mode for:
Windows XP SP 3

Tick run this program as an administrator
Intel i7 2700K (@4.8Ghz) - 8GB Corsair - Windows 8.1-64Bit - Gigabyte GA-Z77X-UD3H - Corsair Force 3 SSD 128GB
Gigabyte GTX780 OC - Benq 120hz LED Monitor

My Custom UI - http://www.swtorui.com/downloads/info81-XpellUI.html

Anokke's Avatar


Anokke
04.01.2012 , 02:13 PM | #3
I have the same problem (Vista user), and I tried using your advice but I don't have SP 3, only up to 2. I tried downloading service pack 3, but I will get a message saying it's not compatible with my system when I try running it.

Ratae's Avatar


Ratae
04.01.2012 , 02:56 PM | #4 Click here to go to the next staff post in this thread. Next  

Hello Mexicanoperson / Anokke,

I’m not sure what steps you have already taken to resolve this, but if you have not done so already, please try using the 'Repair' utility on the launcher. To do this, please click on the button located in the bottom left hand corner of the launcher window. This will open a settings menu where you will be able to find and click on the 'Repair' button.

After that, try to remove and re-add any exceptions for launcher.exe you have in your firewall and anti-virus programs and then restart the Launcher with Administrator privileges.

Please also make sure that you have the latest drivers installed for your graphics card.

If the above does not resolve the problem, please try to work through the troubleshooting steps suggested in this post:
http://www.swtor.com/community/showthread.php?t=9100

If none of this helps, could you please post your Dxdiag and Client log here to enable us to investigate further?
  • Client Logs. These logs are useful if you are experiencing issues after you have clicked ‘Play’ on the launcher and for in-game technical issues. In a default installation these files can be found here:
    • 32bit: C:\Program Files\Electronic Arts\BioWare\Star Wars - The Old Republic\swtor\retailclient\swtor\logs
    • 64bit: C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars - The Old Republic\swtor\retailclient\swtor\logs
    Example file name: Client_20111116T155258_901721.log
Please post the reports within code tags or spoiler tags


Please let us know how you get on.
Ratae | BioWare Customer Service - Forum Support

DukeConan's Avatar


DukeConan
04.01.2012 , 03:37 PM | #5
Not good enough. I have the same problem and I can see 5 posts on the main board all with it. Bad coding. You guys should be invoiced by us for our time. It's a contract. You're not in breach of your obligations by not having a viable product. You first tier guys are posting links, behaving like a fish flapping in a pool that dried up. Can you please escalate this to the third tier and get a response from them? There is some seriously negligent code in the client it's to do with how it handles network latency, and logs incidents of unresponsiveness and I think you have a server that is overloaded and needs a service restart.

Bilka's Avatar


Bilka
04.21.2012 , 06:36 PM | #6
I installed all my updates for Windows 7, changed the compatibility, gave it administrative permission, ran launcher repair, and it still doesn't run.

This is ridiculous.

doctorko's Avatar


doctorko
04.21.2012 , 06:55 PM | #7
same problem here...

HaryyLongNguyen's Avatar


HaryyLongNguyen
04.21.2012 , 07:50 PM | #8
You are lucky that have the laucher appear. Me, after I click on theshort cut the launcher didn't appear(usually it appear 10 secs later after I double click)
"Nothing is precious more than independence, freedom."(Ho Chi Minh)

essthirteen's Avatar


essthirteen
04.21.2012 , 08:32 PM | #9
I've been dealing with this problem, click play and it freezes on the loading screen which apparently is a 1003 error according to their client logs.
I've been having this issue for over a week now and only been able to play twice. I emailed them and their 'specialized team' is onto it apparently but its been a day and heard nothing back at all and no results.

I've updated EVERY single thing I can, all directx, all framework, all system things and drivers etc etc

Its started to annoy the crap out of me and I'm at the point where I wouldn't even reconmend it to anyone after seeing how many problems people encounter with it.

Ratae's Avatar


Ratae
04.25.2012 , 07:23 AM | #10 Click here to go to the next staff post in this thread. Next  
Greetings,

Would it be possible for you to post your Dxdiag and Client logs, so we can get an idea of what might be going wrong?

You can find details on how to get these files here.

Thank you for all your help.

Ratae | BioWare Customer Service - Forum Support