Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Laucher takes forever to start

STAR WARS: The Old Republic > English > Customer Service
Laucher takes forever to start

Pollymanz's Avatar


Pollymanz
12.16.2011 , 04:50 PM | #1
Laucher takes forever to start. When I try to run the launcher.exe it takes forever to come up, I see the edges of the launcher, but when I try to click it, it turns black and I get an error from windows saying the program is not responding... If I start it and wait for like 10min it eventually comes up, its kinda annoying, what to do?^^

Aieny's Avatar


Aieny
12.16.2011 , 04:51 PM | #2
Quote: Originally Posted by Pollymanz View Post
Laucher takes forever to start. When I try to run the launcher.exe it takes forever to come up, I see the edges of the launcher, but when I try to click it, it turns black and I get an error from windows saying the program is not responding... If I start it and wait for like 10min it eventually comes up, its kinda annoying, what to do?^^
That is actually an issue I've been having since beta test weekends, although I don't see any outline on the screen and it does come up after only a couple minutes.

Not really sure what to tell you other than to submit a bug report.

Packetdancer's Avatar


Packetdancer
12.16.2011 , 05:18 PM | #3
This is often caused by a proxy server that doesn't want to play nice with HTTPS being used the way the launcher does, or a misconfigured PAC file. The most frequent cause seems to be a computer that lived on a college campus and inherited campus proxy settings which then is moved off the campus and still tries to use the campus proxy from its new location.

Open Internet Explorer (Launcher honors IE's proxy settings) and go to Tools -> Internet Options, pick Connections and click the LAN Settings button. You'll find your proxy settings there, and can try disabling a proxy if one is set to see if the launcher runs faster after that.
Pahke Stardancer (Jedi Sentinel, Save Taris) / Random CS Forum Participant
Writer, photographer, software engineer, GAMER.


docTOR: SWTOR Launcher Troubleshooting Guide

Angelklaine's Avatar


Angelklaine
12.23.2011 , 12:45 PM | #4
I get this same problem. I click on the launcher and it easily takes up 7-10 minutes for it to come up. No message, no border lines, no errors. Its like if the icon did not work, but it eventually comes up after an extended wait time. I log in, then it does the same thing again loading the actual game. In total, it can take me about 15 min or more to even start playing the game.

Its a home computer, and I haven't been on a college for over 10 years. I have no proxy settings (already checked), and I got no other connection issues. Can't figure out what's the problem here.