Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Game has extreme lag.... ??


xilc's Avatar


xilc
12.16.2011 , 03:16 PM | #1
I am so confused... I have a desktop computer with a quad core processer, 8 gigs of ram and an ati 4600 gfx card...


my laptop has a Geforce 260m and 4gigs ram.... but on both systems, the framerate on lowest detail (all graphics set to low) is like, 5-7 fps?? I'm so confused... How can't my computer run this game?

My desktop can run WoW on ultra everything on 60 fps... why can't I even run this game on low detail ?

The lag, and the framerates drop so slow... its almost as if I'm not moving at all..

ForceSeeker's Avatar


ForceSeeker
12.16.2011 , 03:20 PM | #2
This is a widespread issue, but here is the current band aid fix that works for mose people.

Log into the game.
Go into the graphics settings
At the top, change the settings to HIGH and click APPLY
Then turn Shadows to OFF and click APPLY
Then, if needed, change the settings as you need making sure Shadows stay OFF
Relax, it's just a game.

xilc's Avatar


xilc
12.16.2011 , 03:27 PM | #3
Quote: Originally Posted by ForceSeeker View Post
This is a widespread issue, but here is the current band aid fix that works for mose people.

Log into the game.
Go into the graphics settings
At the top, change the settings to HIGH and click APPLY
Then turn Shadows to OFF and click APPLY
Then, if needed, change the settings as you need making sure Shadows stay OFF

I don't get it... how is this different than simply turning shadows to off normally?

and does this mean change the settings at the top? or change individual setting so it says "custom" at the top ?

ForceSeeker's Avatar


ForceSeeker
12.16.2011 , 03:32 PM | #4
There is a single dropdown box on top of the screen, I can't recall what it is called. I think Graphic Quality or something like that. Set that to HIGH first and then apply. Then turn off Shadows. I think then the top box changes to say Custom. This is a fix that has been working for alot of people. Apparently, BW still has some backend issues with Shadowing and memory leaks.
Relax, it's just a game.

xilc's Avatar


xilc
12.16.2011 , 03:34 PM | #5
Quote: Originally Posted by ForceSeeker View Post
There is a single dropdown box on top of the screen, I can't recall what it is called. I think Graphic Quality or something like that. Set that to HIGH first and then apply. Then turn off Shadows. I think then the top box changes to say Custom. This is a fix that has been working for alot of people. Apparently, BW still has some backend issues with Shadowing and memory leaks.
what exactly is a memory leak? :O and if this fix doesn't work for me will I have to return it to store?

ForceSeeker's Avatar


ForceSeeker
12.16.2011 , 03:37 PM | #6
Here is a link that explains a memory leak: http://en.wikipedia.org/wiki/Memory_leak
Read at your leasure. As for if this doesn't work, you don't return the game because it isn't your system. It's a Bioware issue and their developers need to fix it.
Relax, it's just a game.

Sevvy_Boo's Avatar


Sevvy_Boo
12.16.2011 , 03:39 PM | #7
Do they really have a memory leak issue or is that just speculation? I'd be interested to know. I was shocked at how drastically turning shadows on can simply demolish my framerates. It isn't a constant either, I will be clicking along fine at 60, then BAM drop down drastically, then pop back up. Very weird stuff. Turning shadows off or "low" (I can't tell a difference) fixes it though.
"That's the dumbest thing I've ever heard."

ForceSeeker's Avatar


ForceSeeker
12.16.2011 , 03:41 PM | #8
The memory leak issue is speculation at this point. Nothing definite from BW about it.
Relax, it's just a game.

xilc's Avatar


xilc
12.16.2011 , 03:42 PM | #9
Quote: Originally Posted by Sevvy_Boo View Post
Do they really have a memory leak issue or is that just speculation? I'd be interested to know. I was shocked at how drastically turning shadows on can simply demolish my framerates. It isn't a constant either, I will be clicking along fine at 60, then BAM drop down drastically, then pop back up. Very weird stuff. Turning shadows off or "low" (I can't tell a difference) fixes it though.

how do you see framerates? followed the instructions given to the letter, and yes, it helped, but the game is still VERY laggy on low detail.... so shadows helped, but still not acceptable framerate..

Sevvy_Boo's Avatar


Sevvy_Boo
12.16.2011 , 03:43 PM | #10
I'll keep my eyes peeled then. Hope everyone can resolve their issues and have a nice time playing.
"That's the dumbest thing I've ever heard."