Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Internal Error ABORT: Pointer is null (.\socket.c/385) ?

STAR WARS: The Old Republic > English > Customer Service
Internal Error ABORT: Pointer is null (.\socket.c/385) ?
First BioWare Post First BioWare Post

Zahraal's Avatar


Zahraal
12.13.2011 , 10:14 AM | #1
Launcher error. Please help.

Anguisher's Avatar


Anguisher
12.13.2011 , 11:12 AM | #2
I get the same error. Through some googling I found some old posts in the swtor.com community archives mentioning this error is related to Microsoft Security Essentials (which I use). However, those archives no longer exist so I couldn't open the posts.

How do we allow the launcher.exe in MSE?

Packetdancer's Avatar


Packetdancer
12.13.2011 , 11:20 AM | #3
Pop up the MSE Window (click on the little fortress in the systray). Go to the Settings, then down to Excluded Processes (and enter launcher.exe and SWTOR.exe), and to Excluded Files and Locations (and enter the launcher.exe and SWTOR.exe files).
Pahke Stardancer (Jedi Sentinel, Save Taris) / Random CS Forum Participant
Writer, photographer, software engineer, GAMER.


docTOR: SWTOR Launcher Troubleshooting Guide

Zahraal's Avatar


Zahraal
12.13.2011 , 12:11 PM | #4
i don't have MSE, or can't find it ><

Fridays's Avatar


Fridays
12.13.2011 , 12:37 PM | #5
ok, maybe it helps if you start the launcher as admin...

it doesnt work on my system, and i get the error message even if the launcher isn't run

Packetdancer's Avatar


Packetdancer
12.13.2011 , 12:42 PM | #6
Double-check that your .NET Framework is up-to-date? (Really, just run Windows Update and double-check for anything interesting looking in the updates.)

I'd also check that your Java installation is up-to-date, as the launcher uses java in part as well.
Pahke Stardancer (Jedi Sentinel, Save Taris) / Random CS Forum Participant
Writer, photographer, software engineer, GAMER.


docTOR: SWTOR Launcher Troubleshooting Guide

Zahraal's Avatar


Zahraal
12.13.2011 , 12:46 PM | #7
I noticed when I exit the launcher I have to shut it off in process explorer to be able to restart it. If i dont it tells me i can only have one of such running.

Zahraal's Avatar


Zahraal
12.13.2011 , 12:57 PM | #8
Quote: Originally Posted by Zahraal View Post
I noticed when I exit the launcher I have to shut it off in process explorer to be able to restart it. If i dont it tells me i can only have one of such running.
K Fixed that with an update, and so far havnt gotten the error either.

Fridays's Avatar


Fridays
12.13.2011 , 01:20 PM | #9
ah, net framework update... k,

really, the swtor-community is the best^^

Anguisher's Avatar


Anguisher
12.14.2011 , 05:49 AM | #10
Quote: Originally Posted by Packetdancer View Post
Pop up the MSE Window (click on the little fortress in the systray). Go to the Settings, then down to Excluded Processes (and enter launcher.exe and SWTOR.exe), and to Excluded Files and Locations (and enter the launcher.exe and SWTOR.exe files).
Fixed it, thanks!