Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Game loads to blank screen

MadMustang's Avatar


MadMustang
12.16.2011 , 12:50 PM | #1
Yes I just got my early access and when I click the play button the game just loads to a blank screen.

I took part in the beta and did not have any graphics issues with the last 3 builds.



Stats
2x AMD Athlon 64 FX-74 (3GHz)
4GB Ram
2x GeForce 8600 GTS
Windows 7 64bit
DirectX 11

I uninstalled the beta build and installed using the link provided when the pre-orders became available.
I've also already tried running the repair but I still get the blank screen when I try to play.

Is there a way to reinstall the game with out redownloading the 20+GB again?
Joomla Module - SWTOR: Server Status - HERE
Joomla Module - SWTOR: Recruitment - HERE
I HAVE COME TO KICK *** AND CHEW BUBBLEGUM, ... AND I'M ALL OUT OF BUBBLEGUM!!!!

akidderz's Avatar


akidderz
12.16.2011 , 12:51 PM | #2
same problem. very similar specs.

megotelek's Avatar


megotelek
12.16.2011 , 12:55 PM | #3
Assuming you've already updated to the most current video drivers / Catalyst drivers:

Go to C:\Users\YourUserName\AppData\Local\SWTOR\swtor\se ttings and open the client_settings.ini file. Change the refresh rate to 60 or something your monitor can handle. Save and restart the game.

Make sure you have hidden files/folders viewable, and this location is for Windows 7/Vista, so if you have an earlier version of Windows you may need to use the search function.

Leiloni's Avatar


Leiloni
12.16.2011 , 01:02 PM | #4
Also regarding upgrading your video drivers, make sure you go to the website manually to see what new drivers are available. I had gone into the Device Manager and tried upgrading my drivers there and it told me they were updated. But I was able to go to the AMD website and upgrade my Catalyst drivers to a newer version there - the version I had been on was not working with the game. So just double check on the card's website to be sure there isn't a new version you can't get.
http://www.swtor.com/community/showthread.php?p=1753652#edit1753270

MadMustang's Avatar


MadMustang
12.16.2011 , 01:16 PM | #5
Ya the drives are the latest versions. thanks for the link to the settings file. I was trying to find them.
Joomla Module - SWTOR: Server Status - HERE
Joomla Module - SWTOR: Recruitment - HERE
I HAVE COME TO KICK *** AND CHEW BUBBLEGUM, ... AND I'M ALL OUT OF BUBBLEGUM!!!!