Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Comp Specs/ Low FPS, please help

STAR WARS: The Old Republic > English > Customer Service
Comp Specs/ Low FPS, please help

Binnyskyle's Avatar


Binnyskyle
12.16.2011 , 12:45 PM | #1
Hi all, I have low FPS (10-20 in most places) and am wondering if it is a product of any of the following:

Comp: AMD PHENOM(tm) II X4 810 PROCESSOR 2.60 Ghz
Memory: 6.00 GB RAM
Graphics: ATI Radeon HD 5450

I have also tried a GeForce 9400GT DDR2 1024MB graphics card and have the same low FPS.

The weird thing is I played Beta and my FPS was a lot higher most of the time.

The desktop computer I am using is only 1 year old.

Any help would be appreciated, I am sick of lagging.

Binnyskyle's Avatar


Binnyskyle
12.16.2011 , 12:53 PM | #2
bump, anyone know if my comp sucks?

Knoxpwns's Avatar


Knoxpwns
12.16.2011 , 12:55 PM | #3
I can't give you a solid fix, but I am in the same boat as you.

From everything I am picking up, most if not all of the people experiencing this are running Windows 64bit with an ATI card, so I don't think its fully our side, I also ran perfect on beta and now get like 5 fps

Tiverius's Avatar


Tiverius
12.16.2011 , 12:55 PM | #4
If you're able to, I would try to overclock your CPU. Those CPUs should hit 3 ghz with no problems. Both of those video cards are on the low end. Not sure if you have any money to spend, but you can get a 6870 for $149. If you need to spend a bit less, you can get a 6670 for $80 (after rebate).

DzokISVK's Avatar


DzokISVK
12.16.2011 , 12:55 PM | #5
Try AMD optimalizer, for me it works

Evilashninja's Avatar


Evilashninja
12.16.2011 , 12:57 PM | #6
I'm having the same problems. My lag is so bad I can't even move in game and it's extremely frustrating. I'd really like to play but I can't right now.

Knoxpwns's Avatar


Knoxpwns
12.16.2011 , 12:59 PM | #7
idk if it works for anyone else but I just solved my problem. Shadow quality on low or off. apparently it was on high and pretty much devouring my graphics card. with everything else maxed and shadow at low I am at 50 fps.

baconflip's Avatar


baconflip
12.16.2011 , 12:59 PM | #8
You're in luck, I have the same card as you. All I did in-game was set my graphics to the high preset, then to the low preset, and it was running a lot smoother. However, you can not achieve abnormal FPS rates with the card, since it is outdated by a couple years. I suggest upgrading, I have a new GPU and PSU shipping here right now.

http://www.amd.com/us/products/deskt...-overview.aspx
There is your card, as I said it isn't for high end gaming, but you still will be able to play this game adequately

Tiverius's Avatar


Tiverius
12.16.2011 , 01:02 PM | #9
Here's a link comparing the 5450 vs the 6650 (6670 is faster). http://goo.gl/FfPyi

brendanpc's Avatar


brendanpc
12.16.2011 , 01:06 PM | #10
To OP: the 5450 is a pretty low end card. Considering they had a lot of graphical features turned off for the beta, I'm not surprised you had an FPS drop.

That said, I got a 6970 (I know not everyone can afford to get one of these) and it runs perfectly, but any 68xx or 69xx should be adequate.