Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Error Code 7

First BioWare Post First BioWare Post

Naugor's Avatar


Naugor
12.16.2011 , 11:25 AM | #1 Click here to go to the next staff post in this thread. Next  
***Update***


Hello everyone,

Thank you very much for the logs you have sent in already. If you are experiencing error code 7 while you are trying to launch the game, we would like to ask you to also post your dxdiag reports to help us with further investigation.

However, before you do this, please make sure that you have checked the following:
  • You should make sure that you have the latest version of DirectX installed on your system. For further details please check here.
  • Check that your Graphics card and Sound card have the most recent drivers installed. For instructions on how to update your Graphics card please see here, for Sound cards please see here.
  • You should check that you have the latest Service Pack and Windows Updates installed for your operating system, including optional updates such as .NET Framework and Visual C++ features.
  • Check the minimum specifications of the game, to determine whether your computer may experience difficulties running the game.

Additionally, please check that the PlatformInfo.dll file exists in the following folder (default install):
C:\Program Files (x86)\EA\BioWare\Star Wars - The Old Republic\swtor\retailclient
To get your DXDiag report, follow these instructions:
  1. Press the [Windows] Key + [R] at the same time. (The [Windows] key is the key with the Windows icon on it)
  2. Type in ‘DxDiag’ and press ‘OK’.
  3. This will open the DirectX Diagnostic Tool box.
  4. At the bottom of the box is a ‘Save All information’ button. Press it.
  5. This will open a ‘Save As’ box. Please ensure the text file is named ‘DxDiag’.
  6. Save this to your desktop.
  7. Open the saved file, hit Ctrl+A (select all), and then Ctrl+C (copy).
  8. Paste that information at the bottom of your post. Please use code or spoiler tags.

Thank you very much for continued patience.
Naugor | BioWare Customer Service - Forum Support

Peetza's Avatar


Peetza
12.16.2011 , 11:41 AM | #2
Tagged
remoterenderer.dll pwnd me TWICE

Peetza's Avatar


Peetza
12.16.2011 , 11:43 AM | #3
You should at the very least make this a sticky. There are a lot of people with this problem and at the going rate of 6 posts per minute this thread will disappear in 3 minutes.
remoterenderer.dll pwnd me TWICE

Alexilon's Avatar


Alexilon
12.16.2011 , 11:58 AM | #4
Spoiler


Part one.

Alexilon's Avatar


Alexilon
12.16.2011 , 11:59 AM | #5
Spoiler


Part two.

Mustache_Hero's Avatar


Mustache_Hero
12.16.2011 , 12:02 PM | #6
Spoiler

Peetza's Avatar


Peetza
12.16.2011 , 12:10 PM | #7
Thank you D5-T1!
remoterenderer.dll pwnd me TWICE

Meridian_VI's Avatar


Meridian_VI
12.16.2011 , 12:11 PM | #8
I will be sure to do this after work today. Thank you for moving the issue to sticky note status.

Shaaak's Avatar


Shaaak
12.16.2011 , 12:33 PM | #9
Spoiler

Shaaak's Avatar


Shaaak
12.16.2011 , 12:37 PM | #10
Hi everyone !

I have the same problem so I hope this will help !