Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Laggy on lowest settings with a good computer?

STAR WARS: The Old Republic > English > Customer Service
Laggy on lowest settings with a good computer?

McDaniels's Avatar


McDaniels
12.16.2011 , 09:08 AM | #1
So either the optimization of this game is poor or something is wrong with my computer because I feel pretty strongly that I should be able to run this game above low.

Currently I get consistent frame rate spikes with everything on low, shadows off, flora quality at 0, tree quality 0, etc.

My specs:
CPU: Intel I5 2410M 2.3 GHZ (4 CPUs)
GPU: Nvidia Geforce GT540M
RAM: 6 GB

I feel like those specs should run the game at the very least lagless on low and relatively smoothly on medium... Whats going on? Am I just overestimating my computer, is optimization bad, or do I have some problem with my computer?

AckbarsUnderling's Avatar


AckbarsUnderling
12.16.2011 , 09:52 AM | #2
I'm having the exact same problem. I don't get it.

iain_b's Avatar


iain_b
12.16.2011 , 09:56 AM | #3
Quote: Originally Posted by McDaniels View Post
So either the optimization of this game is poor or something is wrong with my computer because I feel pretty strongly that I should be able to run this game above low.

Currently I get consistent frame rate spikes with everything on low, shadows off, flora quality at 0, tree quality 0, etc.

My specs:
CPU: Intel I5 2410M 2.3 GHZ (4 CPUs)
GPU: Nvidia Geforce GT540M
RAM: 6 GB

I feel like those specs should run the game at the very least lagless on low and relatively smoothly on medium... Whats going on? Am I just overestimating my computer, is optimization bad, or do I have some problem with my computer?
With that computer why do you have everything on low...?

Set everything to high, save the settings and then turn down stuff as necessary.

The big framerate killers are Bloom and Shadows, disable both for better performance.
My Little Pwny
Kulok Dunar, Powertech and GM of MLP. Want to join? Click here for info.

Squadron 1020 & 367

Aieny's Avatar


Aieny
12.16.2011 , 09:57 AM | #4
Try disabling shadows in-game and see if that fixes it.

ModernZombie's Avatar


ModernZombie
12.16.2011 , 09:58 AM | #5
It seems like micro stutters to me. I have a VERY high end rig and no matter what the settings I get stuttering. FPS is high, ping is low, but tons of stutter. With other games this is usually a problem with multi-core or SLI. I hope this gets addressed because it is rather annoying. 120 FPS and I stutter like crazy...

GrolschUK's Avatar


GrolschUK
12.16.2011 , 09:59 AM | #6
The 540M isn't too beefy though is it?

Benchmarked it hits around the same as a 7900 GTX, which is towards the lower end of the GPU list?

Saying that - set it to full and see if it is any better, you may have problems trying to render low quality stuff but the high quality works fine.

Also what speed is the hard drive in the laptop?

Pearasite's Avatar


Pearasite
12.16.2011 , 10:00 AM | #7
Problems on a high end computer often mean that drivers may need updating. Check your graphics card drivers.

Lstn's Avatar


Lstn
12.16.2011 , 10:01 AM | #8
I have a decent laptop, played 2 weekend beta's without fps problems what so ever on high settings, but now I can't enter inside spaces without my fps dropping to below 10 which makes it almost unplayable. I've tried everything disabled/low and even dropped resolution to try counter my problems and continue on with in door missions but nothing helps, its sad to know that beta ran better ( for me at least ).

Lannister's Avatar


Lannister
12.16.2011 , 10:03 AM | #9
I have the exact same problem. But for the first day of playing the game I was running everything on high settings and I was getting 20 - 30fps. I come back to play the next day and I cant even get good fps on low settings. Even on low I can only manage 10 - 20 fps and I get constant lag spikes. This is very weird and I don't know what to do.

I have an icore 5 2.53ghz
6 gigs of ram
AMD Radeon HD 5730

RepublicDiplomat's Avatar


RepublicDiplomat
12.16.2011 , 10:06 AM | #10
Set graphics preset to high and hit apply,Then set preset to low and hit apply,Problem should be fixed...Odd workaround I know but it worked for me and some others *shrugs*