Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

SWTOR Will not play

First BioWare Post First BioWare Post

BrutikusIV's Avatar

04.04.2012 , 10:22 PM | #11

BrutikusIV's Avatar

04.04.2012 , 10:31 PM | #12
ok I take it back, the 57k (save all) from dxdiag was the least of my problems. The other items you wanted me to put in spoiler tabs are like 10-5000 times as much info. Any other way to get you the data you need?

BrutikusIV's Avatar

04.04.2012 , 11:29 PM | #13
Not sure what worked , but I went thru the Task Manager and found Rndll.32 x 2 running after I "Launched the game and Logged IN" , I 'End Process'd" those 2 than clicked Play than also immediately after clicking play I hit the swtor exec in /swtor/swtor/retail version/swtor. game loaded to character select, i exited , restarted with normal launch and normal play and seems well atm. will repost IF I find anything more specific. But hey least im now ingame /wipes sweat from 2 days of clicking play + following insta crash..

Sutii's Avatar

04.04.2012 , 11:37 PM | #14 Click here to go to the next staff post in this thread. Next  
Hello BrutikusIV,

Great to hear that you have got it working, please do reply here if the problem does resurface, and please do include the complete DXDiag report in this event.

Please post the DxDiag within [code] [/code] or [spoiler] [/spoiler] tags

To get your DXDiag report, follow these instructions:
  1. Press the [Windows] Key + [R] at the same time. (The [Windows] key is the key with the Windows icon on it)
  2. Type in ‘DxDiag’ and press ‘OK’.
  3. This will open the DirectX Diagnostic Tool box.
  4. At the bottom of the box is a ‘Save All information’ button. Press it.
  5. This will open a ‘Save As’ box. Please ensure the text file is named ‘DxDiag’.
  6. Save this to your desktop.
  7. Open the saved file, hit Ctrl+A (select all), and then Ctrl+C (copy).
  8. Paste that information at the bottom of your post. Please use code or spoiler tags. If you don’t use these then your DXDiag will fill up the page making it hard to navigate your thread.
I will of course keep my fingers crossed that you will now remain trouble free and able to enjoy Star Wars™: The Old Republic™!
Sutii | BioWare Customer Service - Forum Support

PAULIOO's Avatar

04.05.2012 , 09:49 AM | #15
i got same probs been trying all day with no results reading this and doing what it says but still wnt play

Cerimon's Avatar

04.05.2012 , 10:25 AM | #16 This is the last staff post in this thread.  
Greetings PAULIOO,

Before you email Customer Service, please ensure that you have checked the following:
  • Check that your Graphics card has the most recent drivers installed. For instructions on how to update your Graphics card drivers please see here.
  • You should make sure that you have the latest version of DirectX installed on your system. For further details please check here
  • You should check that you have the latest Service Pack and Windows Updates installed for your operating system including the optional updates such as .NET Framework and Visual C++ features.
  • You should try using the 'Repair' utility on the launcher. To do this please click on the button located in the bottom left hand corner of the launcher window. This will open a settings menu where you will be able to find and click on the 'Repair' button.
  • If you are experiencing this issue after having installed the game from a physical copy, please try running the Fixlauncher.exe located in your installation directory. This is located by default at:
    • 32bit: C:\Program Files\Electronic Arts\BioWare\Star Wars - The Old Republic
    • 64bit: C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars - The Old Republic
If this didn't work try downloading the installer from and running this over your existing installation.

Please also ensure that your computer meets the minimum specifications required to run the game.

You may also want to go through our full launcher troubleshooting which can be found here:

If you are still encountering this issue after checking all of the above, please contact Customer Service.

Please include a DXDiag of your system, your most recent client logs and a description of the exact error encountered.

The client log files are located by default in the installation folder at:

C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars - The Old Republic\swtor\retailclient\swtor\logs

We apologize for any inconvenience caused and Thank You for playing Star Wars: The Old Republic

Cerimon | BioWare Customer Service - Forum Support

BrutikusIV's Avatar

04.05.2012 , 11:15 AM | #17
Windows XP. Once again tried to play the game. Launcher launched, logged in, hit play immediate crash. Tried again : Launched game, Logged IN , (this time I End Processed'd RNDLL.32 in the Task Manager right before I hit PLAY and again game launches flawlessly.

So there's the biggest clue to solving this I can provide. cya I got game .

trueanimus's Avatar

04.05.2012 , 12:14 PM | #18
Quote: Originally Posted by BrutikusIV View Post
Windows XP. Once again tried to play the game. Launcher launched, logged in, hit play immediate crash. Tried again : Launched game, Logged IN , (this time I End Processed'd RNDLL.32 in the Task Manager right before I hit PLAY and again game launches flawlessly.

So there's the biggest clue to solving this I can provide. cya I got game .
goto the icon, right click then choose properties. Goto compatibility tab, click windows xp sp3 or sp2 if you dont have 3. Then set run as admin. Save changes, launch the game. The game needs admin status so it can modify a pagefile. This should solve the problems.

You may also want to make sure you have directx 9.0c installed even though most systems have directx 11. this is because with directx 11 the direct x has to emulate the files from set 9. Having it installed and the d3d9.dll in the swtor main folder will help a ton. This may be why your seeting the RNDLL.32 because its a standard runtime library file for windows that helps emulate other dll files. You can check to see more details on the dll and how to check exactly what its pulling calls to. My guess is it is the command center for the Nvidia card your running, since the game has a HUGE problem with amd cpus and nvidia cards atm. You can disable the Nvidia control center in startup.. or simply close the process before you launch the game.. however, setting the icon for the game to xp compat mode with admin will DEF help a lot, because running vista, this is the only way to make the system see that your vid card has more than 1g ram.

Also make sure you have microsofts net framework software installed and up to date.
Formerly Known as Trueevil of Tarquinas server SWG or Truelydead/trueid/truelock/truedewd/truecan/truelyinsane/truelynsane/trueblu/truebacca of undermine in WoW

BrutikusIV's Avatar

04.05.2012 , 02:58 PM | #19
Well considering I'd had 4,499 failed login attempts and now have 10+ perfect login attempts simply by KILLING rndll.32 ( one of which was tied to NVIDIA) my problem is now fixed at least. I just have to kill that process Everytime prior to hitting the PLAY button. Not sure how rndll.32 works for xp and nvidia but least I have a work around that does work.

I'll leave the rest to Bioware and their nvidia tech speciallists to figure that one out. Surely somewhere somehow it's all tied together even if it has a few flawed links binding the mess.

Edit: Oh and Swtor / Properties / compatability doesn't have a Compatibility Mode for XP or doesn't at least for when you're logged into the Primary account.