Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Horrid FPS


kmufc's Avatar


kmufc
06.05.2012 , 12:16 PM | #761
I bet BW are glad this thread has been forgotten.

I havent forgotten, and the game engine is still poor 6 months later, resulting in random FPS drops / stuttering.

In fact i would say 1.2 made the game even worse for me regarding peformance

Heres a tip BW, next time you make a game dont source a junk free engine that dosent support mulit threading and can handle lots of players on screen, just a thought.

Been playing since Beta Dec 2011, my sub runs out in 12 days, wont be subscribing any more.

I hope 1.3 improves the game engine as rumoured for its current players, but i have my doubts.

SuspectDown's Avatar


SuspectDown
06.05.2012 , 01:25 PM | #762
Quote: Originally Posted by kmufc View Post
I bet BW are glad this thread has been forgotten.

I havent forgotten, and the game engine is still poor 6 months later, resulting in random FPS drops / stuttering.

In fact i would say 1.2 made the game even worse for me regarding peformance

Heres a tip BW, next time you make a game dont source a junk free engine that dosent support mulit threading and can handle lots of players on screen, just a thought.

Been playing since Beta Dec 2011, my sub runs out in 12 days, wont be subscribing any more.

I hope 1.3 improves the game engine as rumoured for its current players, but i have my doubts.
The game IS multi-threaded to an extent. But like ANY modern game (Metro 2033, Crysis 2, BF3) it's not going to use up 100% of any modern 4C CPU.

As for the game having so many issues, I wonder if it's in fact the systems playing them. I've played the game on quite a few systems, and all of them ranged in performance from where they should be. This includes an 1155 Celeron with on-board HD 2000 graphics to a 2500K @ 5 GHz with a 7970. NOT ON ONE system I tried the game on did I think to myself that the game's performance was not parallel to the system's hardware.

Blackcules's Avatar


Blackcules
06.05.2012 , 09:42 PM | #763
How old has this thread been going on without any official response from BW that this is a KNOWN ISSUE? I have a high-end rig that is currently running wow at 185FPS in BGs and idles at 215FPS ON ULTRA (Except shadows). Am I to assume that this game is that much more superior to wow in graphics and I should only expect 20fps in WZs with the current rig I have (16gigs DDR3, i7970, GTX570, 1000WATT PSU)?
Handclappin' *****es since '05

sbjessen's Avatar


sbjessen
06.06.2012 , 01:22 AM | #764
Quote: Originally Posted by Blackcules View Post
How old has this thread been going on without any official response from BW that this is a KNOWN ISSUE?
I was wondering the same thing.. It is very weird that they avoid to come clean with us here.. It is rather stupid actually.. Nothing is worse than just ignoring the problem.. They could atleast admit that there is a problem, and promise us that they are working on fixing it..

SuspectDown's Avatar


SuspectDown
06.06.2012 , 10:02 AM | #765
Quote: Originally Posted by Blackcules View Post
How old has this thread been going on without any official response from BW that this is a KNOWN ISSUE? I have a high-end rig that is currently running wow at 185FPS in BGs and idles at 215FPS ON ULTRA (Except shadows). Am I to assume that this game is that much more superior to wow in graphics and I should only expect 20fps in WZs with the current rig I have (16gigs DDR3, i7970, GTX570, 1000WATT PSU)?
This game is demanding. WoW isn't but that's because it's inferior graphics wise, specifically when it comes to textures. This game is downright beautiful when it comes to max settings inside the fleet. The level of detail is fantastic and it looks better than every other MMO I can think of that's out right now.

I run 2560x1440 max settings (except for shadows off) and 8x AA.

When I did my youtube vids on the forum, WZ/Fleet was averaging 40+ if I remember correctly. This is with a 2500K @ 4.7 GHz and a 7970 at the time.

This game IS demanding. ESPECIALLY PVP/fleet. That's just the fact of the matter.

randalthorr's Avatar


randalthorr
06.20.2012 , 01:09 PM | #766
Since the patch on 19/06/2012 AEST.

http://www.swtor.com/community/showthread.php?t=480440
“Equality is a chain, like obedience. Like fear or uncertainty or self doubt.”
-Darth Bane

Red-Zone Australia

Groovenburge's Avatar


Groovenburge
06.21.2012 , 04:25 PM | #767
I've been playing for a while now and been getting low framerate outside (around about 40 with shadows off and 60 inside) but even if I set everything on low it still stays at around 40 outside, though if the shadows are on high it does knock it down to around 30-35. It also stutters when I move like it is having a hard time loading clutter/charactures/enemies etc. I have everything on high and also V-Sync is on. I also have FXAA with triple buff forced on through the NVidia settings.

AMD Phenom II X6 Processor 2.7GHz
8.00 GB of DDR3 1333Ghz RAM
Windows 7 64bit
ZOTAC GeForce GTX560 2 GB
SATA 1TB 7200RPM
All stock clock

I've also checked for overheating on my GPU. The highest temp is 75ºC and highest load is 99% while playing the game. Idle temp is around 35-40ºC. Also my drivers are upto date, using the 301.42 drivers for my GPU. If there is anything else you guys need just ask and I will try and post it

Emii's Avatar


Emii
06.21.2012 , 05:32 PM | #768
Quote: Originally Posted by dlaselle View Post
I personally think the issues lies within the people computer. I run a fairly new gaming laptop and have yet to see my FPS drop below 30. Normally I am around 70 unless I PVP

Stop blaming Bioware for outdated video cards, and drivers. For those who have NVIDiA cards. They recently released a new version.

For those who have 4 gigs of ram? What do you expect. That should be bare minimal, and therefore expect low settings or low FPS. Upgrade your RAM to 8 + gigs and see the differences.

Check your processes > control alt delete > Start task manager > and the process tab . How many processes are you running. Honestly anything about 50 is to much for Windows Vista

Go the the perfomance tab> CPU Usage should be without running anything around 10% . Ram Usage should be minimal. I have 16 gig ram. Without running anything I have 2 gigs used by other processes.

Now take that into consideration if you only have 4 gigs of ram > that leaves around 2 gigs to the SWTOR? See the issue?
8 gb of ram? are u mad? its so much for this game... the engine is bad... thats way all get low fps on high.

Sekish's Avatar


Sekish
06.21.2012 , 05:58 PM | #769
After reading this, I gave up the idea of buying new hardware. Yes, I like the game. But I'm tired of this lackluster performance in warzones. I can get 30+ FPS in ANY recent game, even if that requires reducing the graphics quality. Not in SWTOR (warzones specifically) though.

Hopefully 1.3 would bring some improvements (as noted in the PTS patch notes). My sub expires in 2-3 days, so I'll be scanning the forum for good news on this department. Hopefully.

trueanimus's Avatar


trueanimus
06.25.2012 , 07:49 AM | #770
Quote: Originally Posted by Emii View Post
8 gb of ram? are u mad? its so much for this game... the engine is bad... thats way all get low fps on high.

according to the release package.. the min for the game is 2 gig.. i think... so 3gig+ should be plenty
Formerly Known as Trueevil of Tarquinas server SWG or Truelydead/trueid/truelock/truedewd/truecan/truelyinsane/truelynsane/trueblu/truebacca of undermine in WoW