Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Trooper Quest: Battle of Corellia Stuck

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Trooper Quest: Battle of Corellia Stuck
First BioWare Post First BioWare Post

bastina's Avatar

02.28.2012 , 10:40 PM | #1
I've finished the Corellia portion of the trooper storyline. So I head back to Coruscant like the mission says, but when I get to Coruscant, the waypoint points me to the black sun territory. Then when I get there, it tells me to go to the Gree Hydrosupply place, but there's nothing in there. No waypoint or cutscene or anything. After I read the mission details, it states to go to the General's office. So I go there, but I cannot enter. Whats up with that? Am I really gonna have to wait weeks to be able to continue on my class quest? Or months since the "Stay Frosty" bonus mission is still bugged and cannot be dropped.

bastina's Avatar

02.29.2012 , 01:06 PM | #2
Found a partial fix which probably lends itself to the cause. I flew back to the republic station, got off, then back on my ship, and went back to coruscant and it updated. Seems like if you take the fleet beacon to the station or use the shuttle to coruscant, it bugs out. Not sure which though.

Sutii's Avatar

03.01.2012 , 07:30 PM | #3 This is the last staff post in this thread.  
Hello bastina,

We are aware of certain issues with the Mission, Battle of Corellia which should be addressed in an upcoming patch. We regret we will be unable to provide further updates on this, but recommend checking future patch notes, which can be found here, for any up to date information.

Additionally you can monitor the Public Test Server for potential upcoming fixes and changes, the patch notes for the Public Test Server can normally be found stickied within the Public Test Server Forum. Please note that the Public Test Server Patch Notes are not final, and can be subject to change.

I am glad to hear that you did manage to work past this problem, as at present it does indeed require that you travel to Coruscant using your own ship and not any other method.

We apologise for any inconvenience caused and thank you for playing Star Wars™: The Old Republic™!
Sutii | BioWare Customer Service - Forum Support

kraby's Avatar

04.12.2012 , 12:38 PM | #4
I guess it isn't fixed in 1.2 and it isn't just "fly in your own ship"

Because I got to this stage today and used my own ship and had EXACTLY the same symptoms.

I used my emergency fleet pass to get back to fleet and then went back and it updated.

I guess just one more of the many, many, many, many bugs in this game.

Aecos's Avatar

04.14.2012 , 04:19 AM | #5
Yeah, i did the same. Used my own ship and still no Gaza. Will try fleet pass and a fly back to coruscant.

ZehBravo's Avatar

04.14.2012 , 07:47 AM | #6
Just had this bug today. Luckily, the simple fix, as stated, is use your fleet pass, get your ship back to Coruscant and then the mission updates.

Since there's a simple work around, shouldn't be that hard to fix... so do it, please!

BigLamn's Avatar

12.08.2012 , 09:38 AM | #7
It's funny but this bug still exists, there is a work around but you would think it would have been fixed by now...I guess we shouldn't be shocked huh
One Sith must contain all the power of the dark side. One Master must decide how that power shall be used. Sharing power is an act of weakness and a violation of the Sith Code.

Zenflyer's Avatar

02.15.2013 , 12:58 PM | #8
Yes indeed this bug STILL exists, just happened to me today! So a whole year into the game and still not fixed!


06.20.2013 , 08:49 AM | #9
Still bugged !
The Droidsmith Legacy - The Progenitor

Valimar's Avatar

06.20.2013 , 12:21 PM | #10
I encountered several bugs when running this missions.

I never had a problem with travelling not counting for me, my bugs were different. First I was heavy screwed by the companion bug, where companions will either stop in place and not fight, or just randomly run off somewhere. That was difficult to deal with, but somehow I made it through.

Next, the general's elite guards kept resetting. I would get them down maybe about 20% in health and they would reset, and start wailing on me at full health. I did manage to find a way around this. There seems to be no limit to their chase range. What I did was pull them all the way back to where the republic forces were gathered. Then I let all the republic commandos wail on them. This worked, although I got no xp from the kills, and no loot.

Between the latency issues people are having, th one time password issues, the stupid hutt cartel loading screeen coming up every few minutes even though there is no need for more loading, and bugged missions like this, this game is really starting to suck. fix this crap devs, fix it now, or you lose a ton of players and a ton of money.