Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Launcher doesn't launch - and no fix works

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Launcher doesn't launch - and no fix works
 
First BioWare Post First BioWare Post

mystercoren's Avatar


mystercoren
12.16.2011 , 04:40 AM | #1
Well, as the old thread was deleted with the launch of EA, here's a new one.

To summarize,

- my launcher.exe launchs only as a process and terminates itself after some time.
- i tried to launch it with literally no other processes running and it still gives the same result.
- i downloaded just fine on my laptop so it definitely isn't a network problem.
- from the resource monitor i was able to see that launcher.exe wasn't waiting on any resource, but was just terminating itself after some time.
- the launcher doesn't give an error when .dll files are missing except icudt.dll and/or libcef.dll.
- i really would like to play this game on my pc and not on my laptop so i am awaiting your help.
- no i don't run a KORG device.
- yes i have tried launching it with sound devices disabled.
- if you could actually supply us with a debugging device that would be appreciated.
- as launcher doesn't move past a certain point, there are no launcher logs.
- the problem isn't with the installation cause i also tried with files from my laptop on which the launcher launchs just fine.
- C O R A L -
- Jedi Shadow DPS -

Ramiraz's Avatar


Ramiraz
12.16.2011 , 04:43 AM | #2
My girlfriend had a similar problem.

She had a copy of the SWTOR folder on her external harddrive from before this problem.

She fixed it by simply deleting the current SWTOR folder and replacing it with her backup from the external harddrive.

kanechart's Avatar


kanechart
12.16.2011 , 04:44 AM | #3
Strange. I had a issue like this before but only through the installer. Found out I had like a old old beta client that left install mark on my computer. I was about extract the uninstaller from the new installer. Since then I formatted. That is always one thing to consider if you have not done that in ages hehe.
Server: The Harbinger (NA)
Faction: The Empire
Character Name: Playground
Youtube Lets Play Series: http://www.swtor.com/community/showthread.php?p=8723272

wasia's Avatar


wasia
12.16.2011 , 05:08 AM | #4
I have the same problem, except first time i started launcher it worked.

My thread there: http://www.swtor.com/community/showt...651#post343651

Kirrah's Avatar


Kirrah
12.16.2011 , 05:12 AM | #5
I had issues with the launcher initally, tried to use the repair function for the game twice. What fixed it for me was going into the game folder and running the Fixlaucher program, has been running fine since for me. Good luck guys.

wasia's Avatar


wasia
12.16.2011 , 05:15 AM | #6
Fixlauncher and even full reinstalling the game doesn't help

MasterWeather's Avatar


MasterWeather
12.16.2011 , 05:17 AM | #7
when i get in to the game i cant change the screen resolution my screen will go black like its trying to work then when it comes back up its the same resolution as b4 i have tried to reinstall and still the same thing plz help me

Elenia's Avatar


Elenia
12.16.2011 , 05:20 AM | #8
Same problem.. Tried everything except for a full format. All programs are shut down, I'm admin, no firewall or anti-virus.. nada.. reinstall twice.. fixlauncher.. everything..

- In beta everything worked fine.
- Unistalled after beta
- Reinstalled
- Launcher doesn't launcher, just shows up in task manager as launcher.exe*32

BUT... Mine DOES show up after 10 to 15 minutes...

had_ol's Avatar


had_ol
12.16.2011 , 06:44 AM | #9
same problem here

Launcher shows up after few minuts on my PC. Windows 7 64 bit, Avast Antivirus, no firewall.

mystercoren's Avatar


mystercoren
12.16.2011 , 08:09 AM | #10
Quote: Originally Posted by Ramiraz View Post
My girlfriend had a similar problem.

She had a copy of the SWTOR folder on her external harddrive from before this problem.

She fixed it by simply deleting the current SWTOR folder and replacing it with her backup from the external harddrive.
I guess I'll try to copy all files from my laptop once again, to see if it changes anything, but I'm not really hopeful.

edit: yep, didn't work.
- C O R A L -
- Jedi Shadow DPS -