Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

***FPS-Issues, fixes and work-arounds!***

STAR WARS: The Old Republic > English > Customer Service
***FPS-Issues, fixes and work-arounds!***

Bloddock's Avatar


Bloddock
12.16.2011 , 01:57 AM | #1
As we all know there is much disturbance in the Force, dark side is clouding our FPS and as much I appreciate a good force choke it has come to my attention there is no freakin "search" button here (another trick of the dark side ) This thread is directed to all of you guys and girls that are out there and are having those horrid FPS lags we have to unite and give the devs a consistent flow of information on our specs and observations as to what might cause this bug to happen.


Also since I haven't noticed any response from the customer service as take this seriously enough to stick all the fixes in one place I will (hopefully with your help).





First of all if you are suffering from FPS lags, pleas make sure

- all of your drivers are up to date (and I mean all drivers not only the graphic one, check especially for your BIOS update, this also includes your audio and stuff like your chip-set, UPDATE EVERYTHING!)

- no additional programs are running in the background i.e. anti-virus soft, up-daters of any kind and so on

- check with any diagnostic programs that your hard-ware is not over heating, this is major issue especially with laptops

- make sure your virus and malware free, those buggers can eat up your resources and you wont even know until its too late


- try and use some optimizing programs that include registry cleaners and start-up managers, the smoother your OS is running the better the experience for you.




Now for all the fixes I have found no this forum and for some strange reason are not put together in one place...


- First of all try changing your resolution, just because your rig can run SKYRIM on ultra details in multi-screen vision and projects 3D holograms of your favorite **** star on to your bed it doesn't mean it will work here... so try and change it ( I had to go as low as 1024x728 and it gave me a stable improvement of 10-15 fps)

- a known bug is that the presets for the graphics are not applying correctly so try and set all of the settings to HIGH apply them and change back to low (people have reported this to work)

- also remember to turn off bloom and shadows ( along with the high to low preference change)

- try and experiment with your graphic card controls. Catalyst Control Center for AMD cards or what ever is the equivalent is for NVIDIA. Try to turn on or off your AA, change your anisotropic filtering and so on

- apparently for people who are using v-sync enabling triple buffering in your graphics card control program has made a difference

- for people that are having problems with changing resolutions, try and go into windowed (full-screen) mode

- if you have a built in graphics card and you are using your more powerful gpu you bought yourself check if SWTOR is on the list of the programs used by the better gpu, this is known for AMD cards, go to your CCC and check your power options, if there is something called "switchable graphics" make sure swtor.exe is assigned to the proper gpu.


- in case you are using a multi-core processor, make sure to check if SWTOR is using just one or more cores, in case it isnt go to windos task manager, right click the process adn set your affinity to all cores.




If there are any more tips and tricks you have discovered please post it here this will help us to sort this mess faster. Also if you are suffering terrible FPS performance I urge you to post your dxdiag file here so that the devs can have a better view of this game breaking issue.

I will add my dxdiag asap (im at work now and using a different machine)

I hope this will help at least some people to get by until this problem is fixed. Apologies for any misspelling or other horrid mistakes since English isnt my first language.

May the Force be with you!

Bloddock's Avatar


Bloddock
12.16.2011 , 05:37 AM | #2
bump*

LordSatoh's Avatar


LordSatoh
12.16.2011 , 05:49 AM | #3
Sometimes changing shadows in game does nothing.

Go to Program Files (x86)/Electronic Arts/Bioware/Star Wars.../swtor/retailclient/ and edit a file called client_defaults.ini (any text editor). Next to doShadows change the word TRUE to FALSE and you have 20-40 FPS increase.

Changing resolution to anything but screens native gonna make the game look bad. This should be THE LAST thing you do.
Peace is a lie...

Hellmet's Avatar


Hellmet
12.16.2011 , 05:49 AM | #4
You do not "First of all try changing your resolution" unless using a FAT monitor.
It's a trap!

Kabaal's Avatar


Kabaal
12.16.2011 , 05:52 AM | #5
Quote: Originally Posted by LordSatoh View Post
Sometimes changing shadows in game does nothing.

Go to Program Files (x86)/Electronic Arts/Bioware/Star Wars.../swtor/retailclient/ and edit a file called client_defaults.ini (any text editor). Next to shadows change the word TRUE to FALSE and you have 20-40 FPS increase.

Changing resolution to anything but screens native gonna make the game look bad. This should be THE LAST thing you do.
Do NOT edit the client_defaults file, you should be editing the client_settings file.
Kabaal 50 Juggernaut | Scotsmania 50 Vanguard | Hurricane 50 Sorcerer
Furian 50 Sentinel | Furķan 50 Commando
Scotsmania 50 Shadow

LordSatoh's Avatar


LordSatoh
12.16.2011 , 05:55 AM | #6
Quote: Originally Posted by Kabaal View Post
Do NOT edit the client_defaults file, you should be editing the client_settings file.
Why are you confusing people dude??
I don't even have something like client_setting file. Editing defaults works like a charm.

And if you come with such bold statement at least give a reason why.
Peace is a lie...

mmjarec's Avatar


mmjarec
12.16.2011 , 05:59 AM | #7
according to the general forums they arent lagging and you just have a crap pc and its not the game, and their CSRS are answering and fixing things instantly.. awesome what you can ignore when you stick your head up your ***.

LordSatoh's Avatar


LordSatoh
12.16.2011 , 06:00 AM | #8
Quote: Originally Posted by mmjarec View Post
according to the general forums they arent lagging and you just have a crap pc and its not the game, and their CSRS are answering and fixing things instantly.. awesome what you can ignore when you stick your head up your ***.
Or be a troll and whiner instead of finding what causes YOUR pc to lag.
I mean being lazy and spoiled by mom giving you everything seems so popular these days.
Peace is a lie...

Hellmet's Avatar


Hellmet
12.16.2011 , 06:01 AM | #9
client_settings.ini is the one to edit.
It's a trap!

Bloddock's Avatar


Bloddock
12.16.2011 , 06:27 AM | #10
Quote: Originally Posted by mmjarec View Post
according to the general forums they arent lagging and you just have a crap pc and its not the game, and their CSRS are answering and fixing things instantly.. awesome what you can ignore when you stick your head up your ***.
Please if you do not have anything constructive do not post here. This is space for those who actually have problems and want them fixed your ignorance and failed troll attempts concern no-one. Thanks and move along.